Opened 7 years ago

Last modified 13 months ago

#40464 assigned defect

libquicktime @1.2.4: error: use of undeclared identifier 'AVCODEC_MAX_AUDIO_FRAME_SIZE'

Reported by: essandess (Steve Smith) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: haspatch Cc: IOOI-SqAR, dbevans (David B. Evans), mojca (Mojca Miklavec), jeremyhu (Jeremy Huddleston Sequoia)
Port: libquicktime

Description (last modified by larryv (Lawrence Velázquez))

port cmds:

$ sudo port clean libquicktime
Password:
--->  Cleaning libquicktime
$ sudo port upgrade libquicktime
--->  Computing dependencies for libquicktime
--->  Fetching archive for libquicktime
--->  Attempting to fetch libquicktime-1.2.4_7.darwin_12.x86_64.tbz2 from http://packages.macports.org/libquicktime
--->  Attempting to fetch libquicktime-1.2.4_7.darwin_12.x86_64.tbz2 from http://lil.fr.packages.macports.org/libquicktime
--->  Attempting to fetch libquicktime-1.2.4_7.darwin_12.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/libquicktime
--->  Fetching distfiles for libquicktime
--->  Verifying checksums for libquicktime
--->  Extracting libquicktime
--->  Applying patches to libquicktime
--->  Configuring libquicktime
--->  Building libquicktime
Error: org.macports.build for port libquicktime returned: command execution failed
Please see the log file for port libquicktime for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libquicktime/libquicktime/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

[inline log cut and attached —larryv]

Attachments (5)

main.log (142.2 KB) - added by larryv (Lawrence Velázquez) 7 years ago.
main.log cut from description
main.2.log (145.9 KB) - added by IOOI-SqAR 7 years ago.
Happend for me to on Darwin MBP15.local 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 7 16:32:41 PDT 2011; root:xnu-1504.15.3~1/RELEASE_X86_64 x86_64 using gcc
main.3.log (41.4 KB) - added by IOOI-SqAR 7 years ago.
taken from /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libquicktime-devel/libquicktime-devel/main.log
libquicktime-ffmpeg.patch (4.6 KB) - added by mojca (Mojca Miklavec) 7 years ago.
a minimum patch to avoid compile errors
libquicktime-cvs.diff (71.5 KB) - added by mojca (Mojca Miklavec) 7 years ago.
full patch against CVS

Download all attachments as: .zip

Change History (18)

Changed 7 years ago by larryv (Lawrence Velázquez)

Attachment: main.log added

main.log cut from description

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Owner: changed from macports-tickets@… to mww@…
Summary: libquicktime fails to comilelibquicktime @1.2.4_7: build failure

Thanks for the ticket. In the future, please Cc relevant port maintainers (port info --maintainers) and don’t paste logs directly into ticket descriptions or comments.

Changed 7 years ago by IOOI-SqAR

Attachment: main.2.log added

Happend for me to on Darwin MBP15.local 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 7 16:32:41 PDT 2011; root:xnu-1504.15.3~1/RELEASE_X86_64 x86_64 using gcc

comment:2 in reply to:  1 Changed 7 years ago by IOOI-SqAR

Replying to larryv@…:

Thanks for the ticket. In the future, please Cc relevant port maintainers (port info --maintainers) and don’t paste logs directly into ticket descriptions or comments.

I just wanted to mention that this still happens for libquicktime-1.2.4_8. See attached main.2.log

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: lars.sonchocky-helldorf@… added

I’d guess libquicktime @1.2.4 is not compatible with the version of ffmpeg we have in MacPorts. libquicktime-devel @1.2.4_20130920 builds fine, however, so use that for now, until a new stable version of libquicktime is released.

comment:4 in reply to:  3 ; Changed 7 years ago by dbevans (David B. Evans)

Replying to ryandesign@…:

I’d guess libquicktime @1.2.4 is not compatible with the version of ffmpeg we have in MacPorts. libquicktime-devel @1.2.4_20130920 builds fine, however, so use that for now, until a new stable version of libquicktime is released.

Yes, that's the case. Ports depending on libquicktime should probably be updated to build with libquicktime-devel by default for now.

comment:5 Changed 7 years ago by dbevans (David B. Evans)

Cc: devans@… added

Cc Me!

comment:6 in reply to:  4 Changed 7 years ago by IOOI-SqAR

Replying to devans@…:

Replying to ryandesign@…:

I’d guess libquicktime @1.2.4 is not compatible with the version of ffmpeg we have in MacPorts. libquicktime-devel @1.2.4_20130920 builds fine, however, so use that for now, until a new stable version of libquicktime is released.

Yes, that's the case. Ports depending on libquicktime should probably be updated to build with libquicktime-devel by default for now.

I uninstalled mjpegtools and all dependencies:

sudo port uninstall mjpegtools
sudo port uninstall --follow-dependencies leaves

and then tried to reinstall it:

sudo port -v install mjpegtools

This time it used libquicktime-devel as dependency. But libquicktime-devel has it's own problems:

:info:configure checking for GL/glx.h... yes
:info:configure ./configure: line 16948: syntax error near unexpected token `ALSA,'
:info:configure ./configure: line 16948: `PKG_CHECK_MODULES(ALSA, alsa >= $ALSA_REQUIRED, have_alsa="true", have_alsa="false")'
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libquicktime-devel/libquicktime-devel/work/libquicktime" && ./configure --prefix=/opt/local --without-gtk --without-alsa --with-libjpeg --with-libpng --with-ffmpeg --with-vorbis=/opt/local --with-libiconv-prefix=/opt/local --with-libintl-prefix=/opt/local --without-doxygen --enable-gpl 
:info:configure Exit code: 2
:error:configure Failed to configure libquicktime-devel, consult /opt/local/var/macports/build/

also see attached log

Last edited 13 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

Changed 7 years ago by IOOI-SqAR

Attachment: main.3.log added

taken from /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libquicktime-devel/libquicktime-devel/main.log

comment:7 Changed 7 years ago by mojca (Mojca Miklavec)

What about patching libquicktime just enough to make it work? There are some issues with CVS on the buildbot among other problems (#43198).

Changed 7 years ago by mojca (Mojca Miklavec)

Attachment: libquicktime-ffmpeg.patch added

a minimum patch to avoid compile errors

Changed 7 years ago by mojca (Mojca Miklavec)

Attachment: libquicktime-cvs.diff added

full patch against CVS

comment:8 Changed 7 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:9 Changed 7 years ago by dbevans (David B. Evans)

Cc: jeremyhu@… added
Keywords: haspatch added

CCing maintainer of libquicktime-devel.

comment:10 Changed 7 years ago by mojca (Mojca Miklavec)

Please not that the patches weren't tested extensively. I just made sure that the code compiled.

comment:11 Changed 7 years ago by mojca (Mojca Miklavec)

Just for the reference, the same report was at #40026.

comment:12 Changed 4 years ago by kurthindenburg (Kurt Hindenburg)

Owner: changed from mww@… to macports-tickets@…
Status: newassigned

comment:13 Changed 13 months ago by ryandesign (Ryan Schmidt)

Summary: libquicktime @1.2.4_7: build failurelibquicktime @1.2.4: error: use of undeclared identifier 'AVCODEC_MAX_AUDIO_FRAME_SIZE'
Note: See TracTickets for help on using tickets.