Opened 10 years ago

Closed 5 years ago

#40566 closed defect (worksforme)

Atlas build fails with missing libf77blas.a when installing Octave

Reported by: jwbwater@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: Atlas


I have been trying to install Octave using MacPorts for a few days now. I've tried each variant with no success, most of the time I just end up killing the process after several hours.

After seeing ticket #40542 I tried:

$sudo port clean atlas
$sudo port -v install atlas +gcc48

and after more than 12 hours it failed complaining of a missing libf77blas.a

I'm using a new 11" Macbook Air running OS X 10.8.5 (12F37) on a 1.3 GHz Core i5 (Haswell) with 4GB of 1600 MHz DDR3 ram.

Attachments (1)

main.2.log (9.7 MB) - added by jwbwater@… 10 years ago.

Change History (5)

Changed 10 years ago by jwbwater@…

Attachment: main.2.log added

comment:1 Changed 10 years ago by Veence (Vincent)

Oops. I can confirm there is a bug during the last phase: AVX intrinsics appear in C code, while gcc48 is not able to compile them. I’ll look into this tomorrow if I have some time, Wednesday at worse

comment:2 Changed 5 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Since atlas no longer has a gcc48 variant, I think this ticket can be safely closed.

comment:3 Changed 5 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:4 Changed 5 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.