Opened 7 years ago

Closed 4 weeks ago

#40788 closed defect (fixed)

Avidemux: Macports application does not work

Reported by: mail@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: mf2k (Frank Schima)
Port: avidemux

Description (last modified by ryandesign (Ryan Schmidt))

Hi there,

I installed avidemux via macports, and used all the variants I saw. Nevertheless I was not able to open a video file (some message like 'no codec for file'). I downloaded Avidemux from their homepage and opened the video, and it worked. Apparently the video has a DIVX50 signature, as Avidemux tells me.

I do not know if it was the slightly different version number (2.6.5 macports vs. 2.6.6 homepage) or that they are packaging an additional codec. But it would be nice to be able to edit that file with the version available from macports.

BTW: The update request ist #40787

Change History (10)

comment:1 Changed 7 years ago by mail@…

Cc: mail@… added

Cc Me!

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: mail@… removed
Description: modified (diff)
Keywords: avidemux codec divx removed

comment:3 Changed 7 years ago by mf2k (Frank Schima)

The application in the /Applications/Macports directory currently does not work correctly. The workaround is to launch the application from the command line.

avidemux

comment:4 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: macsforever2000@… added

I updated avidemux to 2.6.6 in r112283. Did that help?

In what way does using /Applications/MacPorts/Avidemux.app instead of /opt/local/bin/avidemux not work? Please file a new ticket about it.

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:5 Changed 7 years ago by mf2k (Frank Schima)

This is that ticket because it fails in the way described here.

comment:6 Changed 7 years ago by mf2k (Frank Schima)

@ojkastl.de:mail: Please confirm whether or not using the command line workaround in comment:3 worked for you?

comment:7 Changed 7 years ago by mail@…

I installed 2.6.6 today, and tried both ways. Using avidemux on the command line I could open the video. Using the Avidemux.app in /Applications/Macports/ brings up the error.

So it is related to an error in the app. Not to a missing codec or the version.

comment:8 Changed 7 years ago by mf2k (Frank Schima)

Summary: Avidemux: No codec for DIVX50?Avidemux: Macports application does not work

comment:9 Changed 7 years ago by mf2k (Frank Schima)

Cc: mf2k@… added; macsforever2000@… removed

comment:10 Changed 4 weeks ago by ctreleaven (Craig Treleaven)

Resolution: fixed
Status: newclosed

Avidemux has now been updated to 2.7.6 with changes to how the gui app is launched. Assume the reported problem is now fixed. Please reopen if not.

Note: See TracTickets for help on using tickets.