Opened 6 years ago

Closed 6 years ago

#40859 closed defect (fixed)

namebench fails to install on Mavericks

Reported by: dylanryan@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: msy@…
Port: namebench

Description

Reinstalling my port tree after installing Mavericks last night.

Namebench appears to not be able to find Python properly. The error that stops it is this:

CompileC build/namebench.build/Release/namebench.build/Objects-normal/x86_64/main.o main.m normal x86_64 objective-c com.apple.compilers.llvm.clang.1_0.compiler
    cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa
    setenv LANG en_US.US-ASCII
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -x objective-c -arch x86_64 -fmessage-length=0 -fdiagnostics-show-note-include-stack -fmacro-backtrace-limit=0 -Wno-trigraphs -fpascal-strings -Os -Wno-missing-field-initializers -Wno-missing-prototypes -Wno-implicit-atomic-properties -Wno-receiver-is-weak -Wno-arc-repeated-use-of-weak -Wno-missing-braces -Wparentheses -Wswitch -Wno-unused-function -Wno-unused-label -Wno-unused-parameter -Wunused-variable -Wunused-value -Wno-empty-body -Wno-uninitialized -Wno-unknown-pragmas -Wno-shadow -Wno-four-char-constants -Wno-conversion -Wno-constant-conversion -Wno-int-conversion -Wno-bool-conversion -Wno-enum-conversion -Wno-shorten-64-to-32 -Wpointer-sign -Wno-newline-eof -Wno-selector -Wno-strict-selector-match -Wno-undeclared-selector -Wno-deprecated-implementations -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk -fasm-blocks -fstrict-aliasing -Wprotocol -Wdeprecated-declarations -mmacosx-version-min=10.9 -g -fvisibility=hidden -Wno-sign-conversion -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/build/namebench.build/Release/namebench.build/namebench.hmap -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/build/Release/include -I/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/build/namebench.build/Release/namebench.build/DerivedSources/x86_64 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/build/namebench.build/Release/namebench.build/DerivedSources -F/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/build/Release -include /var/folders/6t/ynm9zzz16z78kdgzqnc2v3m00000gq/C/com.apple.DeveloperTools/5.0.1-5A2053/Xcode/SharedPrecompiledHeaders/namebench_Prefix-etfafghqbtociacnntzohkdjzciy/namebench_Prefix.pch -MMD -MT dependencies -MF /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/build/namebench.build/Release/namebench.build/Objects-normal/x86_64/main.d --serialize-diagnostics /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/build/namebench.build/Release/namebench.build/Objects-normal/x86_64/main.dia -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/main.m -o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/build/namebench.build/Release/namebench.build/Objects-normal/x86_64/main.o
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_namebench/namebench/work/namebench-1.3.1/cocoa/main.m:9:9: fatal error: 'Python/Python.h' file not found
#import <Python/Python.h>
        ^
1 error generated.

I do have several Python.h files installed, including the one from Macports python27 (located at /opt/local/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7/Python.h)

Attachments (1)

main.log (48.0 KB) - added by dylanryan@… 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by dylanryan@…

Attachment: main.log added

comment:1 Changed 6 years ago by msy@…

Cc: msy@… added

Cc Me!

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

The problem is the port has python variants but doesn't ever instruct the build system to use the selected python.

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.