Opened 8 years ago

Closed 8 years ago

#40909 closed defect (fixed)

ImageMagick: does not support any image types when .la files are deleted

Reported by: jonasjonas (Frank Hellenkamp) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: mavericks Cc: joelburton (Joel Burton), devernay (Frédéric Devernay)
Port: ImageMagick

Description

I have a new macports installation from the source.

A new install of Imagemagick does not seem to support any image types.

$ identify -list format -v
   Format  Module    Mode  Description
-------------------------------------------------------------------------------

* native blob support
r read support
w write support
+ support for multiple images

The image libraries are installed though:

jpeg @9_1 (active)
openjpeg15 @1.5.0_0 (active)
libpng @1.5.17_0 (active)
tiff @4.0.3_1 (active)

trying to convert any images results in the following error message:

$ convert 20131024/screen_1105_01.png ~/Desktop/test.jpg
convert: no decode delegate for this image format `20131024/screen_1105_01.png' @ error/constitute.c/ReadImage/552.
convert: no images defined `/Users/jonas/Desktop/test.jpg' @ error/convert.c/ConvertImageCommand/3127.

Change History (5)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Keywords: mavericks added
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

Confirmed.

The portfile doesn't do anything differently on Mavericks than on previous OS versions. Please report the problem to the developers of ImageMagick.

comment:2 Changed 8 years ago by joelburton (Joel Burton)

Cc: joel@… added

Cc Me!

comment:3 Changed 8 years ago by devernay (Frédéric Devernay)

Cc: frederic.devernay@… added

Cc Me!

comment:4 Changed 8 years ago by jonasjonas (Frank Hellenkamp)

comment:5 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed
Summary: new imagemagick on mavericks (10.9) does not support any image typesImageMagick: does not support any image types when .la files are deleted

Thanks. Fixed in r112532.

Note: See TracTickets for help on using tickets.