Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#40934 closed defect (invalid)

error:fetch llvm-3.2 is not supported on Mavericks or later.

Reported by: marc@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: mavericks Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: llvm-3.2

Description

Cannot build llvm-3.2, see log below.

Start port

$ sudo port
Password:
MacPorts 2.2.0
Entering interactive mode... ("help" for help, "quit" to quit)

Update ports

selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.2.0 installed,
MacPorts base version 2.2.0 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated

Perform upgrade

upgrade outdated
--->  Extracting adns
Error: org.macports.extract for port adns returned: command execution failed
Please see the log file for port adns for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_adns/adns/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

Error see log file: opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.2/llvm-3.2/main.log

version:1
:msg:archivefetch --->  Computing dependencies for llvm-3.2:info:archivefetch .:debug:archivefetch Searching for dependency: libffi
:debug:archivefetch Found Dependency: receipt exists for libffi
:debug:archivefetch Searching for dependency: perl5
:debug:archivefetch Found Dependency: receipt exists for perl5
:debug:archivefetch Searching for dependency: llvm_select
:debug:archivefetch Found Dependency: receipt exists for llvm_select
:msg:archivefetch
:debug:main Executing org.macports.main (llvm-3.2)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 20
:debug:main euid changed to: 501
:debug:fetch fetch phase started at Fri Oct 25 10:01:08 CEST 2013
:notice:fetch --->  Fetching distfiles for llvm-3.2
:debug:fetch Can't run fetch on this port without elevated privileges. Escalating privileges back to root.
:debug:fetch euid changed to: 0. egid changed to: 0.
:debug:fetch changing euid/egid - current euid: 0 - current egid: 0
:debug:fetch egid changed to: 20
:debug:fetch euid changed to: 501
:debug:fetch Executing proc-pre-org.macports.fetch-fetch-0
:error:fetch llvm-3.2 is not supported on Mavericks or later.
:error:fetch org.macports.fetch for port llvm-3.2 returned: unsupported platform
:debug:fetch Error code: NONE
:debug:fetch Backtrace: unsupported platform
    while executing
"$pre $targetname"
:info:fetch Warning: targets not executed for llvm-3.2: org.macports.destroot org.macports.fetch org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build
:notice:fetch Please see the log file for port llvm-3.2 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.2/llvm-3.2/main.log

The error

:error:fetch llvm-3.2 is not supported on Mavericks or later.
:error:fetch org.macports.fetch for port llvm-3.2 returned: unsupported platform

Ok, thats it for now.

Change History (4)

comment:1 Changed 4 years ago by marc@…

Oops, command must be:

Perform upgrade

selfupdate
...
Warning: Deactivate forced.  Proceeding despite dependencies.
--->  Cleaning cctools-headers
--->  Uninstalling cctools-headers @839_0
--->  Cleaning cctools-headers
--->  Installing cctools-headers @839_0
--->  Activating cctools-headers @839_0
--->  Cleaning cctools-headers
--->  Fetching archive for llvm_select
--->  Attempting to fetch llvm_select-0.2_0.darwin_13.noarch.tbz2 from http://lil.fr.packages.macports.org/llvm_select
--->  Attempting to fetch llvm_select-0.2_0.darwin_13.noarch.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/llvm_select
--->  Attempting to fetch llvm_select-0.2_0.darwin_13.noarch.tbz2 from http://packages.macports.org/llvm_select
--->  Fetching distfiles for llvm_select
--->  Verifying checksums for llvm_select
--->  Extracting llvm_select
--->  Configuring llvm_select
--->  Building llvm_select
--->  Staging llvm_select into destroot
--->  Unable to uninstall llvm_select @0.2_0, the following ports depend on it:
--->  	llvm-3.2 @3.2_1
--->  	llvm-3.2 @3.2_2
Warning: Uninstall forced.  Proceeding despite dependencies.
--->  Deactivating llvm_select @0.2_0
--->  Unable to deactivate llvm_select @0.2_0, the following ports depend on it:
--->  	llvm-3.2 @3.2_2
Warning: Deactivate forced.  Proceeding despite dependencies.
--->  Cleaning llvm_select
--->  Uninstalling llvm_select @0.2_0
--->  Cleaning llvm_select
--->  Installing llvm_select @0.2_0
--->  Activating llvm_select @0.2_0
--->  Cleaning llvm_select
--->  Fetching archive for llvm-3.2
--->  Attempting to fetch llvm-3.2-3.2_2.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/llvm-3.2
--->  Attempting to fetch llvm-3.2-3.2_2.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/llvm-3.2
--->  Attempting to fetch llvm-3.2-3.2_2.darwin_13.x86_64.tbz2 from http://packages.macports.org/llvm-3.2
--->  Computing dependencies for llvm-3.2
--->  Fetching distfiles for llvm-3.2
Error: llvm-3.2 is not supported on Mavericks or later.
Error: org.macports.fetch for port llvm-3.2 returned: unsupported platform
Please see the log file for port llvm-3.2 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.2/llvm-3.2/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
[Users/marc] > less /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.2/llvm-3.2/main.log
Error: Unrecognized action "port less"
Last edited 4 years ago by marc@… (previous) (diff)

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Cc jeremyhu@… added
  • Keywords mavericks added; llvm-3.2 Mavericks 10.9 removed
  • Resolution set to invalid
  • Status changed from new to closed

As the error message says, "llvm-3.2 is not supported on Mavericks or later". Use llvm-3.3 or llvm-3.4 instead.

comment:3 follow-up: Changed 4 years ago by marc@…

True,

Just did a reinstall of MacPort using this guide https://trac.macports.org/wiki/Migration.

Reinstall ports

To reinstall your ports:

    Save the list of installed ports:

    port -qv installed > myports.txt

    Uninstall all installed ports:

    sudo port -f uninstall installed

    Clean any partially-completed builds:

    sudo port clean all

    Browse myports.txt and install the ports that you actually want to use (as opposed to those that are only needed as dependencies) one by one, remembering to specify the appropriate variants:

    sudo port install portname +variant1 +variant2 …

Thanks for the quick comment, but i already reinstalled my software. Should have upgraded to llvm-3.3 of higher. Problem solved Thanks.

comment:4 in reply to: ↑ 3 Changed 4 years ago by kunthar@…

Replying to marc@…:

If you have installed bash > 4.2 or gcc > 4.8 before with macports, never attempt to use this way. System becomes useless. I had same symptom as it is indicated in http://trac.macports.org/wiki/MavericksProblems missing /usr/bin/gnutar issue. I have followed the migration plan and downloaded new pkg for Mavericks And also i had to download command line tools manually from https://developer.apple.com/downloads/index.action?q=xcode because xcode-select --install failed from shell. But it was impossible to reinstall any port packages. Hope this helps someone as me!

Note: See TracTickets for help on using tickets.