Opened 9 years ago

Closed 9 years ago

#41032 closed defect (invalid)

installing cmake on Mavericks 10.9 fails with expat

Reported by: peter.lichtner@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: mavericks Cc:
Port: expat

Description (last modified by ryandesign (Ryan Schmidt))

[gravenstein-2:~] lichtner% sudo port install cmake
--->  Computing dependencies for cmake
--->  Dependencies to be installed: libidn gettext expat libiconv gperf ncurses openssl zlib xz
--->  Fetching archive for expat
--->  Attempting to fetch expat-2.1.0_0.darwin_13.x86_64.tbz2 from http://packages.macports.org/expat
--->  Attempting to fetch expat-2.1.0_0.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/expat
--->  Attempting to fetch expat-2.1.0_0.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/expat
--->  Fetching distfiles for expat
--->  Verifying checksums for expat
--->  Extracting expat
--->  Configuring expat
Error: Failed to configure expat, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_expat/expat/work/expat-2.1.0/config.log
Error: org.macports.configure for port expat returned: configure failure: command execution failed
Error: Failed to install expat
Please see the log file for port expat for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_expat/expat/main.log
Error: The following dependencies were not installed: libidn gettext expat libiconv gperf ncurses openssl zlib xz
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port cmake failed

Attachments (1)

main.log (7.3 KB) - added by peter.lichtner@… 9 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: mavericks added
Owner: changed from macports-tickets@… to ryandesign@…
Port: expat added

It works fine for me. Attach the main.log, please, so I can see what went wrong.

Changed 9 years ago by peter.lichtner@…

Attachment: main.log added

comment:2 Changed 9 years ago by peter.lichtner@…

Issue resolved and closed: Xcode was installed in incorrect location.

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

Glad you got it working.

Note: See TracTickets for help on using tickets.