Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#41048 closed defect (invalid)

valgrind and mavericks

Reported by: axet (Alexey Kuznetsov) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: matt@…, fabian@…
Port: valgrind

Description (last modified by mf2k (Frank Schima))

:error:fetch valgrind 3.8.1 is only compatible with Mac OS X 10.5, 10.6, 10.7 and 10.8
:error:fetch org.macports.fetch for port valgrind returned: incompatible Mac OS X version
:debug:fetch Error code: NONE
:debug:fetch Backtrace: incompatible Mac OS X version

Change History (12)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to raimue@…

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers valgrind).

comment:2 Changed 7 years ago by matt@…

Cc: matt@… added

Cc Me!

comment:3 in reply to:  1 Changed 7 years ago by axet (Alexey Kuznetsov)

Replying to macsforever2000@…:

Thanks for mention. I'm being to fast sometimes.

comment:4 Changed 7 years ago by raimue (Rainer Müller)

Resolution: invalid
Status: newclosed

I don't understand this bug report. The statement you posted is correct, valgrind simply does not support OS X 10.9 (not even a development version from their trunk, I already tried to update valgrind-devel).

There is nothing else that can be done in MacPorts about that, as we are merely packaging up what upstream provides. Implementing support for OS X 10.9 should be done upstream at valgrind.org.

comment:5 Changed 7 years ago by martin.prebio@…

Just as a reference: Homebrew has the same issue and already opened a bug report upstream: https://bugs.kde.org/show_bug.cgi?id=326724

comment:6 Changed 7 years ago by fabian@…

Cc: fabian@… added

Cc Me!

comment:7 Changed 7 years ago by bgschaid@…

I think closing this bug is not the best solution. Nobody expects the MacPorts-team to fix a problem in the upstream. But acknowledging that the bug is there would help endusers (especially as only non-closed bugs seem to be listed at http://trac.macports.org/wiki/MavericksProblems) who are planning their upgrade

Don't know if it is possible to add custom states to Trac, but a bug state "Waiting for Upstream-Fix" would make it clear to everyone that

a) there is a problem b) it is not the fault of the port-maintainers

comment:8 Changed 7 years ago by raimue (Rainer Müller)

I can't deny that the existence of the problem is not properly acknowledged by the invalid state.

However, introducing new bug states or resolutions to Trac should certainly not be discussed in a single bug report, but on the macports-dev (see MailingLists).

comment:9 Changed 7 years ago by johnhutchins@…

https://bugs.kde.org/show_bug.cgi?id=326724 - the patch here works to get Valgrind working on Mavericks.

Homebrew already has a formula for installing Valgrind based on that patch and the link has instructions for installing it as well.

Since apparently getting support from Macports for this same issue is deemed "invalid" and I assume other macport users will have the same issue and will google it and come to this page, I think it is important to point out this valid work around.

Last edited 7 years ago by johnhutchins@… (previous) (diff)

comment:10 Changed 7 years ago by rurban@…

This patch works fine, confirmed.

When can we expect a updated valgrinded package based on valgrind-3.10.0.SVN+patch326724 ? It is better than no package at all.

comment:11 in reply to:  9 Changed 7 years ago by raimue (Rainer Müller)

This ticket is invalid because the original reporter failed to articulate any problem. Yes, the upstream release of valgrind is not supported on OS X 10.9 Mavericks. That is properly addressed by prohibiting the installation of this port on this particular platform. If the hidden intention of this ticket was to actually get valgrind to work on OS X 10.9 Mavericks, then that needs to be fixed upstream as MacPorts merely packages what upstream provides.

Furthermore, such a request filed against valgrind is definitely invalid, as the valgrind port tracks the stable version as released by upstream. There is also a valgrind-devel port which tracks the upstream version control system with irregular updates (e.g. tested snspshots with significant fixes or new features).

The patch provided in the upstream bug report has not even landed in the upstream version control system yet. Taking patches from a bug tracker that did not get proper review from the upstream developers sounds like a bad idea, as it is still a moving target. Other software management tools like Homebrew might have a different policy for this matter, but that is not something that influences the work done by MacPorts.

As soon as this lands in upstream version control I will happily update the valgrind-devel port. If I miss that, please open a new ticket against valgrind-devel and request an update of that port.

comment:12 in reply to:  9 Changed 6 years ago by gallafent

Replying to johnhutchins@…:

https://bugs.kde.org/show_bug.cgi?id=326724 - the patch here works to get Valgrind working on Mavericks.

There are two attachments there … one containing a single patch, the other with a set exported from a git repo somewhere. Which one (or both) did you use to get things working?

Note: See TracTickets for help on using tickets.