Opened 8 years ago

Closed 8 years ago

#41059 closed defect (duplicate)

octave-devel: error: use of undeclared identifier 'CGDisplayBitsPerPixel'

Reported by: jendrek@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: mavericks Cc: onurdomanic@…, davydden@…, lord@…
Port: octave-devel

Description (last modified by ryandesign (Ryan Schmidt))

MacPorts 2.2.1 installed from scratch after complete cleanup of 2.2.0.

All dependence installed fine, but the last part, building octave-devel, fails.

arpack installed with +atlas (as suggested during building dependencies for octave-devel).

Here is the critical part from the log (I believe):

...
:info:build display.cc:75:16: error: use of undeclared identifier 'CGDisplayBitsPerPixel'
:info:build           dp = CGDisplayBitsPerPixel (display);
:info:build                ^
:info:build 1 error generated.
:info:build make[3]: *** [liboctinterp_la-display.lo] Error 1
:info:build make[3]: *** Waiting for unfinished jobs....
:info:build In file included from bitfcns.cc:33:
:info:build In file included from ./ov-uint64.h:40:
:info:build In file included from ./ov-intx.h:36:
:info:build In file included from ./ov-base-int.h:37:
...

Attachments (1)

main.log (1.0 MB) - added by jendrek@… 8 years ago.
main.log from octave-devel build

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by onurdomanic@…

Cc: onurdomanic@… added

Cc Me!

Changed 8 years ago by jendrek@…

Attachment: main.log added

main.log from octave-devel build

comment:2 Changed 8 years ago by jendrek@…

Cc: jendrek@… added

Cc Me!

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: jendrek@… removed
Description: modified (diff)
Keywords: mavericks added; octave-devel display CGDisplayBitsPerPixel removed
Owner: changed from macports-tickets@… to michaelld@…
Port: octave-devel added
Priority: HighNormal
Summary: octave-devel fails to build in Mavericks on MBP-R 15"octave-devel: error: use of undeclared identifier 'CGDisplayBitsPerPixel'

comment:4 Changed 8 years ago by davydden@…

Cc Me!

comment:5 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: davydden@… added

comment:6 Changed 8 years ago by lord@…

Cc: lord@… added

Cc Me!

comment:7 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #40806.

Note: See TracTickets for help on using tickets.