Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#41076 closed defect (fixed)

montage: non-void function 'closefitsfile' should return a value

Reported by: cdeil (Christoph Deil) Owned by: robitaille@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: haspatch Cc: geobartman@…, ryandesign (Ryan Schmidt)
Port: montage

Description (last modified by ryandesign (Ryan Schmidt))

Montage fails to build on OS X 10.9.

Here's the full log: https://gist.github.com/cdeil/7228982

The reason is possibly #30656.

Tom, maybe you could report this to the Montage developers and ask them to fix it?

Attachments (1)

patch-lib-src-two_plane_v1.1-initdistdata.c.diff (394 bytes) - added by cdeil (Christoph Deil) 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by robitaille@…

I think we'll have more luck making a patch for this (MacPorts can apply patches) and then sending it to the developers in case they want to include it. I think they are short on time so I don't think they will be able to fix this. If we can't get it to work, I think we'll have to remove this port. I don't have time to work on a patch though, but if anyone else would like to, please do!

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: robitaille@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to robitaille@…
Summary: montage: build fails on OS X 10.9montage: non-void function 'closefitsfile' should return a value

#30656 isn't related. The bug is as it says in the logfile: "error: non-void function 'closefitsfile' should return a value". We should fix the function so that it returns a value, or is declared as void if it's not supposed to return one. This is a fairly elementary software development problem that the developers of this software should have no difficulty fixing.

Changed 7 years ago by cdeil (Christoph Deil)

comment:3 Changed 7 years ago by cdeil (Christoph Deil)

I've attached a patch that should fix the build (untested).

I'll report it at http://montage.ipac.caltech.edu now.

comment:4 Changed 7 years ago by cdeil (Christoph Deil)

No reply from the Montage devs.

Tom, maybe you can commit the attached patch in Macports, then?

comment:5 Changed 7 years ago by neilcrighton@…

I can confirm that this fix does work on Mavericks. Thanks for the patch!

comment:6 Changed 7 years ago by cdeil (Christoph Deil)

Tom, could you please commit the attached patch?

comment:7 Changed 7 years ago by wkerzendorf (Wolfgang Kerzendorf)

@tom also can confirm that works on mavericks. Is there anything we can help with?

comment:8 Changed 7 years ago by mf2k (Frank Schima)

Cc: geobartman@… added

Cc reporter of duplicate #43852.

comment:9 Changed 7 years ago by robitaille@…

Sorry for not getting around to this sooner - this should now be committed in r120815

Try running selfupdate in an hour, then let me know if you are able to now install it, and I'll close this issue.

comment:10 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: haspatch added
Resolution: fixed
Status: newclosed

For future reference, you should not increase the port's revision when you're only fixing a build failure.

comment:11 Changed 7 years ago by cdeil (Christoph Deil)

Works for me on Mac OS X 10.9.

comment:12 Changed 6 years ago by macports@…

I also applied the patch to the upcoming Debian package.

Note: See TracTickets for help on using tickets.