Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#41084 closed defect (fixed)

xylib: fatal error: 'tr1/memory' file not found

Reported by: laew_rena24@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: mavericks Cc: uvw2@…
Port: xylib

Description (last modified by ryandesign (Ryan Schmidt))

The building failed in Maverick OS X 10.9. The main.log shows that

:info:configure checking tr1/memory usability... no
:info:configure checking tr1/memory presence... no
:info:configure checking for tr1/memory... no
.
.
.
.
.
:info:build ./cache.h:31:11: fatal error: 'tr1/memory' file not found
:info:build # include <tr1/memory>
:info:build           ^
:info:build 1 error generated.
:info:build make[2]: *** [cache.lo] Error 1
:info:build make[2]: *** Waiting for unfinished jobs....
:info:build mv -f .deps/gsas.Tpo .deps/gsas.Plo
:info:build mv -f .deps/brucker_raw.Tpo .deps/brucker_raw.Plo
:info:build mv -f .deps/xylib.Tpo .deps/xylib.Plo
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_xylib/xylib/work/xylib-1.2/xylib'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_xylib/xylib/work/xylib-1.2'
:info:build make: *** [all] Error 2

Attachments (2)

xylib.patch (951 bytes) - added by uvw2@… 6 years ago.
fityk.log (139.5 KB) - added by laew_rena24@… 6 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: mavericks added; Fityk removed
Owner: changed from macports-tickets@… to ryandesign@…
Summary: xylib build fails in Maverick OSX 10.9xylib: fatal error: 'tr1/memory' file not found
Type: updatedefect

Changed 6 years ago by uvw2@…

Attachment: xylib.patch added

comment:2 Changed 6 years ago by uvw2@…

I make a patch attached this ticket (attachment:xylib.patch), but this patch is just a quick hack. In my Mac (mavericks 10.9 and Xcode 5), xylib can be compiled as follows:

Patch file of xylib.patch is downloaded in Downloads folder (~/Downloads/). In Terminal.app,

cd /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/math/xylib
sudo patch -p1 < ~/Downloads/xylib.patch
sudo port install xylib

Is this patch right?

Last edited 6 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 in reply to:  2 ; Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to uvw2@…:

Is this patch right?

I don't think so. Whereas before it was using system includes, you've changed it to use boost includes.

But I am not a C/C++ programmer; this problem needs to be solved by the developers of xylib. I have reported the problem to them.

comment:4 in reply to:  3 ; Changed 6 years ago by laew_rena24@…

Replying to ryandesign@…:

Replying to uvw2@…:

Is this patch right?

I don't think so. Whereas before it was using system includes, you've changed it to use boost includes.

But I am not a C/C++ programmer; this problem needs to be solved by the developers of xylib. I have reported the problem to them.

What about fityk, is it running very well with this patch?

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: uvw2@… added

comment:6 Changed 6 years ago by wojdyr@…

Hello, upstream developer here. I think this patch will work. Any shared_ptr should do, it can be from <tr1/memory> or from <memory> or from <boost/tr1/memory.hpp> or from <boost/shared_ptr.hpp>, wherever it is present.

The problem is caused by a bug in configure script, it will be fixed in the next release.

comment:7 in reply to:  4 Changed 6 years ago by uvw2@…

Replying to laew_rena24@…:

Replying to ryandesign@…:

Replying to uvw2@…:

Is this patch right?

I don't think so. Whereas before it was using system includes, you've changed it to use boost includes.

But I am not a C/C++ programmer; this problem needs to be solved by the developers of xylib. I have reported the problem to them.

What about fityk, is it running very well with this patch?

Unfortunately, the building of fityk failed in OS X 10.9, regardless of xylib.

comment:8 in reply to:  6 ; Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Replying to wojdyr@…:

Hello, upstream developer here. I think this patch will work. Any shared_ptr should do, it can be from <tr1/memory> or from <memory> or from <boost/tr1/memory.hpp> or from <boost/shared_ptr.hpp>, wherever it is present.

The problem is caused by a bug in configure script, it will be fixed in the next release.

I'd rather apply your upstream patch; done in r113354.

Changed 6 years ago by laew_rena24@…

Attachment: fityk.log added

comment:9 in reply to:  8 Changed 6 years ago by laew_rena24@…

Replying to ryandesign@…:

Replying to wojdyr@…:

Hello, upstream developer here. I think this patch will work. Any shared_ptr should do, it can be from <tr1/memory> or from <memory> or from <boost/tr1/memory.hpp> or from <boost/shared_ptr.hpp>, wherever it is present.

The problem is caused by a bug in configure script, it will be fixed in the next release.

I'd rather apply your upstream patch; done in r113354.

It's correct, the building of fityk failed in OS X 10.9, the file.log is attached it…

comment:10 Changed 6 years ago by ryandesign (Ryan Schmidt)

This ticket is about xylib and is resolved. The fityk ticket is #41218.

Note: See TracTickets for help on using tickets.