Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#41132 closed defect (fixed)

luajit installs differently depending on whether lua is installed

Reported by: ryandesign (Ryan Schmidt) Owned by: anddam (Andrea D'Amore)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cooljeanius (Eric Gallager)
Port: luajit

Description

luajit does not declare a dependency on lua but installs itself differently depending on whether lua is installed. (From a comment in the Portfile: "luajit doesn't depends on lua but if lua 5.2 is installed we're going to change the conf file so we can use 5.2 extensions") But we have a buildbot that produces binary packages of luajit. And the buildbots never have any ports installed other than the dependencies of the port being built. So on the buildbot, lua will not be installed when luajit is being built. So apparently this means users cannot use any lua 5.2 extensions if they get the binary from our server. Or if they install lua after installing luajit.

The port should be changed to always build the same way, and presumably that way should be to allow the use of lua 5.2 extensions if lua is installed.

Adding a dependency on the lua port just to find its version number might be overkill, but you could define a variable for the lua version, and remind yourself to update it and revbump luajit if and when lua is updated to a newer version.

Change History (3)

comment:1 Changed 8 years ago by anddam (Andrea D'Amore)

Status: newassigned

comment:2 Changed 8 years ago by anddam (Andrea D'Amore)

Resolution: fixed
Status: assignedclosed

Removed the check on installed lua port in r118222, actually by reading the portfile I couldn't figure why I came up with that part since luajit is actually 5.1 API+ABI compatbile by design.

I added the lua 5.2 partial compatibility option to CFLAGS by default. Ticket closed.

comment:3 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.