Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#41193 closed defect (invalid)

Atlas could not detect any fortran compiler

Reported by: gorkemozkaya@… Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: atlas

Description

I am trying to install octave, but it gets stuck at installing atlas, complaining about the missing fortran compiler.

--->  Configuring atlas
Selected C compiler: /opt/local/bin/clang-mp-3.3
Error: org.macports.configure for port atlas returned: Atlas could not detect any fortran compiler. If you really don’t need the fortran interface to be built, please use the +nofortran option, else install a fortran compiler (e.g. gcc4X) before building Atlas.

I made sure that gfortran is installed on my system:

$ which gfortran
/usr/local/bin/gfortran

Attachments (1)

main.log (13.5 KB) - added by gorkemozkaya@… 7 years ago.
atlas.main logs

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by gorkemozkaya@…

Attachment: main.log added

atlas.main logs

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to vince@…
Port: atlas added
Summary: Octave does not install, because atlas cannot find the fortran compilerAtlas could not detect any fortran compiler

comment:2 in reply to:  description Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

Replying to gorkemozkaya@…:

I am trying to install octave, but it gets stuck at installing atlas, complaining about the missing fortran compiler.

--->  Configuring atlas
Selected C compiler: /opt/local/bin/clang-mp-3.3
Error: org.macports.configure for port atlas returned: Atlas could not detect any fortran compiler. If you really don’t need the fortran interface to be built, please use the +nofortran option, else install a fortran compiler (e.g. gcc4X) before building Atlas.

I made sure that gfortran is installed on my system:

$ which gfortran
/usr/local/bin/gfortran

MacPorts will not use anything you have installed in /usr/local. In fact, installing things in /usr/local is unsupported and can cause problems with MacPorts, so please uninstall anything you have there.

As the error message said, either install a gcc4x port, or use the +nofortran variant.

comment:3 Changed 7 years ago by deodato_art@…

I run into this issue too, and I think it is a proper bug. IMHO if the installation of atlas by default requires a Fortran compiler, either this should be among its dependencies, or the default should be changed not to require it (i.e. pass +nofortran by default). The current situation is that MacPorts fails on "sudo port install octave", which to me is not ideal :-)

comment:4 Changed 7 years ago by Veence (Vincent)

Okay. I’ll have atlas build gfortran4.7 if it is not present and the +nofortran option is not selected, since most of the packages that depend on Atlas expect the Fortran API to be built.

comment:5 in reply to:  4 ; Changed 6 years ago by lpagani91

Replying to vince@…:

Okay. I’ll have atlas build gfortran4.7 if it is not present and the +nofortran option is not selected, since most of the packages that depend on Atlas expect the Fortran API to be built.

Too bad. I have ifort installed and it does not find it either... Isn't it silly to have to install a worse compiler ? BTW, 15 months later, gfortran4.7 is not being built as a dependency of atlas. It still stops complaining it finds no fortran compiler. Can't we give an option to Macport to tell it which fortran to use ?

I have installed the macport g95 compiler and it still complains it finds no fortran compiler. It is definitely a bug IMHO.

Last edited 6 years ago by lpagani91 (previous) (diff)

comment:6 in reply to:  5 ; Changed 6 years ago by seanfarley (Sean Farley)

Replying to laurent.pagani@…:

Replying to vince@…:

Okay. I’ll have atlas build gfortran4.7 if it is not present and the +nofortran option is not selected, since most of the packages that depend on Atlas expect the Fortran API to be built.

Too bad. I have ifort installed and it does not find it either... Isn't it silly to have to install a worse compiler ?

Then please tell Intel to provide an open source version of their fortran compiler. By design, MacPorts won't use things outside MacPorts itself and the system provided by Apple. This is to guarantee reproducibility and reduce a maintainer's burden. If you want ATLAS to be compiled with ifort, then you'll have to do it yourself (or with a custom portfile).

Side note: why are you compiling ATLAS if you have ifort? Aren't you supposed to be using Intel's MKL?

comment:7 in reply to:  6 Changed 6 years ago by lpagani91

Replying to sean@…:

Then please tell Intel to provide an open source version of their fortran compiler. By design, MacPorts won't use things outside MacPorts itself and the system provided by Apple. This is to guarantee reproducibility and reduce a maintainer's burden. If you want ATLAS to be compiled with ifort, then you'll have to do it yourself (or with a custom portfile).

OK I understand. But I have installed g95 with MacPorts and it did not help either (the only fortran compiler I identified, did not see gfortran in the "port search fortran" list.) Anyway, I downloaded the source and compiled it eventually.

Side note: why are you compiling ATLAS if you have ifort? Aren't you supposed to be using Intel's MKL?

Because I am trying to compile a third-party code which wants ATLAS and FFTW to proceed.

Last edited 6 years ago by lpagani91 (previous) (diff)

comment:8 Changed 6 years ago by Veence (Vincent)

Salut, salut! (Suite en anglais)

I can add a specific option for ifort to be recognised. But I’m not sure it is supported by Atlas. Does it produce object files compatible with gcc?

comment:9 in reply to:  8 Changed 6 years ago by lpagani91

Replying to vince@…:

Salut, salut! (Suite en anglais)

I can add a specific option for ifort to be recognised. But I’m not sure it is supported by Atlas. Does it produce object files compatible with gcc?

Bonjour,

I am not 100% sure but I think it does. I use a small c program which I compile with gcc and link with my main fotran program compiled with ifort. Is that enough ? But ATLAS should have seen my g95 compiler installed with port. Is there not a problem here ?

Note: See TracTickets for help on using tickets.