Opened 7 years ago

Closed 7 years ago

#41216 closed defect (fixed)

openjpeg: build fails when openjpeg15 is active

Reported by: drkatastro@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: mark.macports@…, trungnob@…, Ionic (Mihai Moldovan), dllau@…, papachoco (Carlos Sanchez), ryandesign (Ryan Schmidt)
Port: openjpeg

Description

openjpeg 2.0.0 is unable to upgrade since the move to Mavericks.

Attachments (5)

openjpeg_port_issue.log (35.2 KB) - added by drkatastro@… 7 years ago.
Logfile from openjpeg problem
clean_openjpeg_err.log (74.4 KB) - added by drkatastro@… 7 years ago.
main.log (141.0 KB) - added by daniele@… 7 years ago.
I also can't upgrade, and there seems to be no file in the dist where OPJ_LRCP and OPJ_BOOL are defined.
main.2.log (140.6 KB) - added by info@… 7 years ago.
Same here. Problem exists since update to Maverick, clean didn't help.
main.3.log (50.1 KB) - added by mark.macports@… 7 years ago.
same problem here... tried clean... no help.

Download all attachments as: .zip

Change History (21)

Changed 7 years ago by drkatastro@…

Attachment: openjpeg_port_issue.log added

Logfile from openjpeg problem

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: mavericks added; Mavericks removed
Owner: changed from macports-tickets@… to mcalhoun@…
Port: openjpeg added

clean and try again; that wasn't a clean attempt. openjpeg installs fine for me on Mavericks.

Changed 7 years ago by drkatastro@…

Attachment: clean_openjpeg_err.log added

comment:2 in reply to:  1 Changed 7 years ago by drkatastro@…

sudo port clean was run, followed up attempting to upgrade again, and the same error appeared. New logfile attached.

Replying to ryandesign@…:

clean and try again; that wasn't a clean attempt. openjpeg installs fine for me on Mavericks.

Changed 7 years ago by daniele@…

Attachment: main.log added

I also can't upgrade, and there seems to be no file in the dist where OPJ_LRCP and OPJ_BOOL are defined.

Changed 7 years ago by info@…

Attachment: main.2.log added

Same here. Problem exists since update to Maverick, clean didn't help.

comment:3 Changed 7 years ago by info@…

Cc: info@… added

Cc Me!

Changed 7 years ago by mark.macports@…

Attachment: main.3.log added

same problem here... tried clean... no help.

comment:4 Changed 7 years ago by mark.macports@…

Cc: mark.macports@… added

Cc Me!

comment:5 Changed 7 years ago by trungnob@…

Cc: trungnob@… added

Cc Me!

comment:6 Changed 7 years ago by Ionic (Mihai Moldovan)

This is due to a previous openjpeg header file, incorrectly overriding the "new" openjpeg.h when building openjpeg.

sudo port clean openjpeg
sudo mv /opt/local/include/openjpeg.h /opt/local/include/openjpeg.h.RM
sudo port -sv upgrade openjpeg

If openjpeg was updated successfully:

sudo rm /opt/local/include/openjpeg.h.RM
Last edited 7 years ago by Ionic (Mihai Moldovan) (previous) (diff)

comment:7 Changed 7 years ago by Ionic (Mihai Moldovan)

Cc: ionic@… added

Cc Me!

comment:8 in reply to:  6 Changed 7 years ago by daniele@…

Replying to ionic@…:

This is due to a previous openjpeg header file, incorrectly overriding the "new" openjpeg.h when building openjpeg. […]

This worked for me, thanks!

comment:9 Changed 7 years ago by info@…

Worked for be, too. Thank you!!!

comment:10 Changed 7 years ago by info@…

Cc: info@… removed

Cc Me!

comment:11 Changed 7 years ago by mf2k (Frank Schima)

ionic is correct, but please use this method to build openjpeg:

sudo port -f deactivate openjpeg15
sudo port clean openjpeg
sudo port install openjpeg
sudo port activate openjpeg15

comment:12 Changed 7 years ago by neverpanic (Clemens Lang)

If you're on trunk, trace mode (port -t install) should avoid this problem.

For now, openjpeg should probably use the conflicts_build PortGroup to encode this problem in the Portfile, or change the include paths in a way that the local header is found first.

comment:13 Changed 7 years ago by jsaucier@…

Watch out here from manually removing the /opt/local/include/openjpeg.h file... poppler (and maybe other package) will failed to build or upgrade now.

Maybe after upgrading openjpeg 2.0, rename the file back to /opt/local/include/openjpeg.h in place of deleting it.

comment:14 Changed 7 years ago by ryandesign (Ryan Schmidt)

I suspect #40656 would fix this.

comment:15 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: dllau@… papachoco@… ryandesign@… added
Keywords: mavericks removed
Summary: port openjpeg returned: command execution failedopenjpeg: build fails when openjpeg15 is active

Has duplicates #41882, #41888

comment:16 in reply to:  14 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Replying to ryandesign@…:

I suspect #40656 would fix this.

Yup. Applying a local version of this fix to openjpeg in r115051.

Note: See TracTickets for help on using tickets.