Opened 5 years ago

Closed 5 years ago

#41222 closed defect (duplicate)

Ports can't install tightvnc on Mac Os X 10.9

Reported by: bukovskiy.k@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: tightvnc

Description (last modified by ci42)

Error: Processing of port tightvnc failed

Log ->

:notice:configure --->  Configuring tightvnc
:debug:configure Using compiler 'Xcode Clang'
:debug:configure Executing org.macports.configure (tightvnc)
:debug:configure Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_tightvnc/tightvnc/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.9' IMAKECPP='/usr/bin/cpp'
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_tightvnc/tightvnc/work/vnc_unixsrc" && xmkmf'
:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_tightvnc/tightvnc/work/vnc_unixsrc" && xmkmf
:info:configure mv -f Makefile Makefile.bak
:info:configure imake -DUseInstalled -I/opt/local/lib/X11/config
:info:configure In file included from Imakefile.c:15:
:info:configure /opt/local/lib/X11/config/Imake.tmpl:2144:10: fatal error: ' X11 .rules' file not found
:info:configure #include ProjectRulesFile
:info:configure          ^
:info:configure /opt/local/lib/X11/config/Imake.tmpl:2142:35: note: expanded from macro 'ProjectRulesFile'
:info:configure # define ProjectRulesFile       Concat3(<,TopLevelProject,.rules>)
:info:configure                                         ^
:info:configure /opt/local/lib/X11/config/Imake.rules:256:23: note: expanded from macro 'Concat3'
:info:configure #define Concat3(a,b,c)a/**/b/**/c
:info:configure                       ^
:info:configure 1 error generated.
:info:configure imake: Exit code 1.
:info:configure   Stop.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_tightvnc/tightvnc/work/vnc_unixsrc" && xmkmf
:info:configure Exit code: 1
:error:configure org.macports.configure for port tightvnc returned: xmkmf failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: xmkmf failure: command execution failed
    while executing
"$procedure $targetname"
:info:configure Warning: targets not executed for tightvnc: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Please see the log file for port tightvnc for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_tightvnc/tightvnc/main.log

Attachments (1)

main.log (58.6 KB) - added by bukovskiy.k@… 5 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 5 years ago by ci42

Description: modified (diff)

Please attach the full log file from a clean build attempt.

In the future please remember to use WikiFormatting.

Changed 5 years ago by bukovskiy.k@…

Attachment: main.log added

comment:2 in reply to:  1 Changed 5 years ago by bukovskiy.k@…

Replying to ciserlohn@…:

Please attach the full log file from a clean build attempt.

In the future please remember to use WikiFormatting.

Thank you. I have attached full log file in the main post.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #40862.

Note: See TracTickets for help on using tickets.