Opened 8 years ago

Closed 5 years ago

#41309 closed defect (fixed)

buildbots don't support fetching from CVS

Reported by: ryandesign (Ryan Schmidt) Owned by: skarulkar@…
Priority: Normal Milestone:
Component: server/hosting Version:
Keywords: Cc:
Port:

Description

The buildbots failed to build the vineserver port with this error:

Logging in to :pserver:anonymous@osxvnc.cvs.sourceforge.net:2401/cvsroot/osxvnc
CVS password: cvs [login aborted]: connect to osxvnc.cvs.sourceforge.net(216.34.181.112):2401 failed: Connection refused

Can the buildbots' firewall be modified to allow CVS fetches?

Change History (7)

comment:1 Changed 7 years ago by jmroot (Joshua Root)

Owner: changed from wsiegrist@… to skarulkar@…

comment:2 Changed 7 years ago by skarulkar@…

Will this be for the build server or for build-slaves ? -Shree

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

The build-slaves.

comment:4 Changed 7 years ago by skarulkar@…

I can certainly put in a request to open the port 2401. I see the following IP address, that should stay the same I suppose?

da0601a-dhcp120:~ local$ dig osxvnc.cvs.sourceforge.net +short
216.34.181.112
Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

We would want fetching from any CVS server to work, not just that one.

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Same with git (#41880), subversion, mercurial, in case those aren't set up yet.

comment:7 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Shree fixed this some time ago.

Note: See TracTickets for help on using tickets.