Opened 15 years ago

Closed 14 years ago

Last modified 5 years ago

#4136 closed defect (fixed)

BUG: Fortune will not compile; missing regex.h

Reported by: sigint@… Owned by: tobypeterson
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: michel.salim@…, markd@…
Port: fortune

Description (last modified by ryandesign (Ryan Schmidt))

I applied the patch supplied in Bug #3010, and got fortune to install.

When I run /opt/local/bin/nethack now, I get the following output (and no nethack):

/opt/local/bin/nethack: line 51: cd: /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_games_nethack/work/destroot/opt/local/share/nethackdir: No such file or directory
/opt/local/bin/nethack: line 57: /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_games_nethack/work/destroot/opt/local/share/nethackdir/nethack: No such file or directory
/opt/local/bin/nethack: line 57: exec: /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_games_nethack/work/destroot/opt/local/share/nethackdir/nethack: cannot execute: No such file or directory

I made it work by manually hacking /opt/local/bin/nethack thusly:

--- nethack~	2005-07-27 01:19:06.000000000 +1000
+++ nethack	2005-07-27 01:17:58.000000000 +1000
@@ -1,7 +1,8 @@
 #!/bin/sh
 #	SCCS Id: @(#)nethack.sh	3.4	1990/02/26
 
-HACKDIR=/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_games_nethack/work/destroot/opt/local/share/nethackdir
+HACKDIR=/opt/local/share/nethackdir
 export HACKDIR
 HACK=$HACKDIR/nethack
 MAXNROFPLAYERS=4

I'm pretty sure the manual hacking I did on termcap.c didn't cause this, so I thought I'd post the problem/solution to make it googleable/reusable. If it's caused by my tinkering/stupidity, I'm sorry for spamming you.

Thanks,
-s

Change History (10)

comment:1 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to toby@…

assigning to maintainer;

comment:2 Changed 15 years ago by pguyot (Paul Guyot)

What's the link with fortune????

comment:3 Changed 15 years ago by sigint@…

(In reply to comment #2)

What's the link with fortune????

The link is that I copied the wrong bug report in. Sorry. I'll fix it.

-s

comment:4 Changed 15 years ago by sigint@…

Summary: Fortune will not runFortune will not compile; missing regex.h
  1. The dune quotes file no longer exists on the next; it's been removed from the downloads, but not

the unzip/install part.

  1. Fortune won't compile. Looks to be the same problem as libcompat -- no regex.h -- so #define

NO_REGEX 1 at the top of fortune.c, and it compiles. This is at the cost of being able to use -m to search for fortunes.

More detail if you need it.

Thanks,

-s

comment:5 Changed 15 years ago by toby@…

Cc: michel.salim@… added

* Bug 2773 has been marked as a duplicate of this bug. *

comment:6 Changed 15 years ago by toby@…

Status: newassigned

comment:7 Changed 15 years ago by mww@…

Summary: Fortune will not compile; missing regex.hBUG: Fortune will not compile; missing regex.h

comment:8 Changed 15 years ago by toby@…

Should probably switch over to http://www.redellipse.net/code/fortune, since the fortune port's original distfile has sort of disappeared off the face of the earth.

comment:9 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: fixed
Status: assignedclosed

Fortune has been updated and it now installs ok for me. Run selfupdate and try again.

comment:10 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: fortune added
Note: See TracTickets for help on using tickets.