Opened 7 years ago

Closed 6 years ago

#41379 closed defect (fixed)

Terminal @0.4.5_1 fails to configure: vte >= 0.17.1 not found though vte 0.34.8_0 exists

Reported by: vnebel@… Owned by: afb@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: rudloff@…, ryandesign (Ryan Schmidt), diekhans (Mark Diekhans), cooljeanius (Eric Gallager), dbevans (David B. Evans)
Port: Terminal

Description (last modified by mf2k (Frank Schima))

My Mac is running on Mavericks with Xcode 5.0.2. port version is 2.2.1, so everything should be up to date. I tried "port clean all" to solve the issue, but it didn't help: When I try to install Terminal, installation stops with

Error: Failed to configure Terminal. 

I attach the file I am referred to. It looks like vte >= 0.17.1 is required and not found. I tried to fix this by installing vte manually, getting version 0.34.8_0, but the problem persists! May be a bug in the ports base, that the version is not detected?

Volker

Attachments (2)

config.log (51.9 KB) - added by vnebel@… 7 years ago.
config.log
main.log (117.3 KB) - added by vnebel@… 7 years ago.
main.log

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by vnebel@…

Attachment: config.log added

config.log

Changed 7 years ago by vnebel@…

Attachment: main.log added

main.log

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to afb@…

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers Terminal).

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: rudloff@… added

Has duplicate #41551.

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Terminal is asking pkg-config whether a package called "vte" exists. With the currently version of vte, 0.34.9, there is no such package, but there is one called "vte-2.90". This seems odd... how should a port like Terminal wanting to know if vte exists know in advance what version of vte is installed?

Terminal is out of date; I'll file a separate ticket for that. The latest version of Terminal has the same problem however.

comment:4 Changed 7 years ago by diekhans (Mark Diekhans)

Cc: markd@… added

Cc Me!

comment:5 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:6 in reply to:  3 Changed 6 years ago by cooljeanius (Eric Gallager)

Replying to ryandesign@…:

Terminal is asking pkg-config whether a package called "vte" exists. With the currently version of vte, 0.34.9, there is no such package, but there is one called "vte-2.90".

The "vte" port changed package names when updating from the gnome2 version to the gnome3 version. It used to just leave off the version suffix. The version of vte that leaves off the version suffix installs in parallel with the one that adds it, so we could have ports for both...

Terminal is out of date; I'll file a separate ticket for that.

(This is #41861 for anyone else who might come across this and wonder)

comment:7 Changed 6 years ago by dbevans (David B. Evans)

Resolution: duplicate
Status: newclosed

New port vte-gtk2-compat, based on vte 0.28.2, committed in r122208. This port installs in parallel with the current gtk3 compatible version of vte and satisfies the vte requirements of this port. However, additional problems remain.

See the aforementioned #41861 for details. I am closing this ticket as a duplicate of that ticket, since the most current activity to get this port working is there.

comment:8 Changed 6 years ago by dbevans (David B. Evans)

Cc: devans@… added

Cc Me!

comment:9 Changed 6 years ago by afb@…

Resolution: duplicate
Status: closedreopened

comment:10 Changed 6 years ago by afb@…

Resolution: fixed
Status: reopenedclosed

Fixed, r126600.

Note: See TracTickets for help on using tickets.