Opened 7 years ago

Closed 7 years ago

#41391 closed defect (fixed)

litecoin fails to build on Mavericks

Reported by: mkae (Marko Käning) Owned by: mkae (Marko Käning)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Mavericks Cc:
Port: litecoin

Description

:info:build /usr/bin/clang++ -c -pipe -fstack-protector-all -D_FORTIFY_SOURCE=2 -O2 -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.9 -pthread -fdiagnostics-show-option -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -Wstack-protector -DQT_GUI -DBOOST_THREAD_USE_LIB -DBOOST_SPIRIT_THREADSAFE -DUSE_QRCODE -DUSE_UPNP=1 -DSTATICLIB -DUSE_IPV6=1 -DHAVE_BUILD_INFO -DMAC_OSX -DMSG_NOSIGNAL=0 -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/local/share/qt4/mkspecs/macx-g++ -Ibuild -I/opt/local/Library/Frameworks/QtCore.framework/Versions/4/Headers -I/opt/local/Library/Frameworks/QtNetwork.framework/Versions/4/Headers -I/opt/local/Library/Frameworks/QtGui.framework/Versions/4/Headers -I/opt/local/include/db48 -Isrc -Isrc/json -Isrc/qt -Isrc/leveldb/include -Isrc/leveldb/helpers -I/opt/local/include/db48 -I/opt/local/Library/Frameworks/QtGui.framework/Versions/4/Headers -I/opt/local/Library/Frameworks/QtNetwork.framework/Versions/4/Headers -I/opt/local/Library/Frameworks/QtCore.framework/Versions/4/Headers -I/opt/local/include -Ibuild -F/opt/local/Library/Frameworks -F/opt/local/lib -o build/optionsdialog.o src/qt/optionsdialog.cpp
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_finance_litecoin/litecoin/work/litecoin-0.8.5.1/src/leveldb'
:info:build /usr/bin/clang++ -I. -I./include -DOS_MACOSX -DLEVELDB_PLATFORM_POSIX -pipe -fstack-protector-all -D_FORTIFY_SOURCE=2 -O2 -c db/builder.cc -o db/builder.o
:info:build /usr/bin/clang++ -I. -I./include -DOS_MACOSX -DLEVELDB_PLATFORM_POSIX -pipe -fstack-protector-all -D_FORTIFY_SOURCE=2 -O2 -c db/c.cc -o db/c.o
:info:build /usr/bin/clang++ -I. -I./include -DOS_MACOSX -DLEVELDB_PLATFORM_POSIX -pipe -fstack-protector-all -D_FORTIFY_SOURCE=2 -O2 -c db/db_impl.cc -o db/db_impl.o
:info:build /usr/bin/clang++ -I. -I./include -DOS_MACOSX -DLEVELDB_PLATFORM_POSIX -pipe -fstack-protector-all -D_FORTIFY_SOURCE=2 -O2 -c db/db_iter.cc -o db/db_iter.o
:info:build In file included from src/qt/optionsdialog.cpp:6:
:info:build In file included from src/netbase.h:10:
:info:build src/serialize.h:911:10: error: class member cannot be redeclared
:info:build     void insert(iterator it, std::vector<char>::const_iterator first, std::vector<char>::const_iterator last)
:info:build          ^
:info:build src/serialize.h:898:10: note: previous declaration is here
:info:build     void insert(iterator it, const_iterator first, const_iterator last)
:info:build          ^
:info:build src/serialize.h:911:10: error: redefinition of 'insert'
:info:build     void insert(iterator it, std::vector<char>::const_iterator first, std::vector<char>::const_iterator last)
:info:build          ^
:info:build src/serialize.h:898:10: note: previous definition is here
:info:build     void insert(iterator it, const_iterator first, const_iterator last)
:info:build          ^
:info:build 2 errors generated.
.
.
.

Change History (1)

comment:1 Changed 7 years ago by mkae (Marko Käning)

Resolution: fixed
Status: newclosed

Fixed in r114828

Note: See TracTickets for help on using tickets.