Opened 4 years ago

Last modified 19 months ago

#41431 new defect

kdenlive fails to run on 10.9 if gavl is installed

Reported by: mkae (Marko Käning) Owned by: mkae (Marko Käning)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: mavericks haspatch Cc:
Port: kdenlive

Description

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff8ac580c2 close + 10
1   libkdeui.5.dylib              	0x000000010b2315f7 KCrash::defaultCrashHandler(int) + 247
2   libsystem_platform.dylib      	0x00007fff90a705aa _sigtramp + 26
3   ???                           	0x0000000116873200 0 + 4672926208
4   libmltfrei0r.dylib            	0x0000000116de3f10 fill_param_info + 656
5   libmlt.6.dylib                	0x000000010cbbd1bc mlt_repository_metadata + 172
6   libmlt++.3.dylib              	0x000000010cbebf83 Mlt::Repository::metadata(mlt_service_type, char const*) const + 67
7                                 	0x000000010ae575df initEffects::parseEffectFile(EffectsList*, EffectsList*, EffectsList*, QString, QStringList, QStringList, Mlt::Repository*) + 1951
8                                 	0x000000010ae4a143 initEffects::parseEffectFiles(QString const&) + 5795
9                                 	0x000000010ace4991 MainWindow::MainWindow(QString const&, KUrl const&, QString const&, QWidget*) + 1665
10                                	0x000000010ace4267 main + 4151
11  libdyld.dylib                 	0x00007fff910495fd start + 1

Attachments (1)

frei0r-plugins-conflicts-gavl.diff (473 bytes) - added by ddennedy (Dan Dennedy) 3 years ago.
fix by adding conflicts gavl

Download all attachments as: .zip

Change History (16)

comment:1 Changed 4 years ago by ddennedy (Dan Dennedy)

Unable to reproduce using a build I made on 10.8 running on 10.9. It appears to be crashing on a particular frei0r plugin in /opt/local/lib/frei0r-1. You can try removing them one-by-one to see if their is a particular plugin causing the problem.

comment:2 Changed 4 years ago by mkae (Marko Käning)

Thanks for the hint!

I've found these three plugins to be crashing the application:

rgbparade.so
scale0tilt.so
vectorscope.so

How to proceed?

comment:3 Changed 4 years ago by ddennedy (Dan Dennedy)

The patches in ticket #39505 need to be checked in. Thought, it looks like the version number needs bump now. I have been using my local port with this change, which is why I did not crash. I have yet to migrate my macports install since upgrade to 10.9. So, it would take me a while to update the patches and test them. Can you help in this regard?

comment:4 Changed 4 years ago by ddennedy (Dan Dennedy)

Actually, revision was bumped in that patch. I think that should be enough, right?

comment:5 Changed 4 years ago by mkae (Marko Käning)

Yep, those patches do the job. Shall I commit those changes?

comment:6 Changed 4 years ago by mkae (Marko Käning)

  • Resolution set to fixed
  • Status changed from new to closed

Done in r113609.

comment:7 Changed 4 years ago by mkae (Marko Käning)

  • Resolution fixed deleted
  • Status changed from closed to reopened

Since the three plugins crash kdenlive this ticket should not be marked closed and the behaviour get reported upstream instead.

comment:8 Changed 4 years ago by ddennedy (Dan Dennedy)

Oh well, I have done all I am going to do on this. If you want to clutter your bug tracker with the bugs for upstream project bugs instead of just build-related issues, then so be it.

comment:9 Changed 4 years ago by mkae (Marko Käning)

Yup, I just didn't want to forget about this one, since I am referencing it on https://trac.macports.org/wiki/KDEProblems/KDETickets and it appeared there as resolved up to now... And, no, I didn't want to make you do more on this! ;-)

comment:10 Changed 3 years ago by mkae (Marko Käning)

  • Summary changed from kdenlive fails to run on 10.9 to kdenlive fails to run on 10.9 if gavl is installed

Hi Dan,

I was wondering whether I should simply add

conflicts gavl

to the Portfile... That should fix it for everyone trying to install this port?

Marko

comment:11 Changed 3 years ago by ddennedy (Dan Dennedy)

Is the problem that if one installs gavl manually before building the frei0r port, then the frei0r build sees gavl and builds the gavl-dependent plugins?

comment:12 Changed 3 years ago by mkae (Marko Käning)

Dan, I haven't analysed this any further, just stumbled over this and thought I could avoid the trouble by not making gavl and kdenlive coinstallable. I have don't have any experience with all these ports and their (conflicting) inter-dependencies, sorry... :-/

comment:13 Changed 3 years ago by ddennedy (Dan Dennedy)

Yes, I think so although it appears conflicts keyword is under-documented. In any case, probably the conflicts line should be added to frei0r-plugins/Portfile, not Kdenlive since it is frei0r upstream that has the optional dependency on gavl. I still have to migrate my macports install since the upgrade to 10.10. So, I can do it eventually, probably within a week or two. I like to test my changes since I do not edit portfiles on a daily basis. :-) Or, you can make and commit that change.

comment:14 Changed 3 years ago by mkae (Marko Käning)

Dan, if you don't mind I stay patient and leave it to your testing. Yes, you're right, the conflicts should surely go to frei0r-plugins/Portfile then. Thanks for caring! :)

Changed 3 years ago by ddennedy (Dan Dennedy)

fix by adding conflicts gavl

comment:15 Changed 19 months ago by mf2k (Frank Schima)

  • Keywords haspatch added
  • Owner changed from dan@… to mk@…
  • Status changed from reopened to new

Assigning this to mk since he is the current port maintainer.

Note: See TracTickets for help on using tickets.