Opened 9 years ago

Closed 7 months ago

Last modified 7 months ago

#41434 closed defect (fixed)

magicpoint @1.13a - fatal error: ' X11 .rules' file not found

Reported by: d0wntime Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: mavericks Cc: diekhans (Mark Diekhans), cooljeanius (Eric Gallager), MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: magicpoint

Description (last modified by mf2k (Frank Schima))

Magicpoint fails to compile. The build stops during imake with. Strangely, this appears to be the same as #34972 and #34503 (submitted by me 5/18/12), only now with OS X 10.9 and Xcode 5.0.2.

configure: creating ./config.status
config.status: creating Imakefile
config.status: creating image/Imakefile
config.status: creating sample/Imakefile
config.status: creating contrib/mgp2html.pl
config.status: creating contrib/mgp2latex.pl
config.status: creating contrib/mgpnet
config.status: creating mgpembed.pl
be sure to generate Makefile from Imakefile, by xmkmf and make Makefiles
imake -DUseInstalled -I/opt/local/lib/X11/config
In file included from Imakefile.c:15:
/opt/local/lib/X11/config/Imake.tmpl:2144:10: fatal error: ' X11 .rules' file not found
#include ProjectRulesFile
         ^
/opt/local/lib/X11/config/Imake.tmpl:2142:35: note: expanded from macro 'ProjectRulesFile'
# define ProjectRulesFile       Concat3(<,TopLevelProject,.rules>)
                                        ^
/opt/local/lib/X11/config/Imake.rules:256:23: note: expanded from macro 'Concat3'
#define Concat3(a,b,c)a/**/b/**/c
                      ^
1 error generated.
imake: Exit code 1.
  Stop.
Command failed: /opt/local/bin/xmkmf && make Makefiles
Exit code: 1
Error: org.macports.configure for port magicpoint returned: command execution failed
Warning: targets not executed for magicpoint: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Please see the log file for port magicpoint for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_magicpoint/magicpoint/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port magic point failed

Attachments (1)

tightvnc.main.log (67.2 KB) - added by mf2k (Frank Schima) 9 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Ok, this is the issue where clang does not work as a C preprocessor for imake; until magicpoint is fixed to not use imake, we need to use GCC's cpp instead.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

We had encountered this problem before in #34503 but were unable to reproduce it. It's now re-appearing because in Xcode 5, clang is the only included compiler.

comment:3 Changed 9 years ago by mf2k (Frank Schima)

Keywords: mavericks added
Port: tightvnc added

I see the exact same error in trying to build tightvnc on Mavericks.

comment:4 Changed 9 years ago by mf2k (Frank Schima)

Cc: macsforever2000@… added

Cc Me!

Changed 9 years ago by mf2k (Frank Schima)

Attachment: tightvnc.main.log added

comment:5 Changed 9 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:6 in reply to:  3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Port: tightvnc removed

Replying to macsforever2000@…:

I see the exact same error in trying to build tightvnc on Mavericks.

This ticket is for magicpoint. #40862 is for tightvnc.

comment:7 Changed 9 years ago by d0wntime

I see that the port file changed, but the problem persists. Sorry if you already knew this, but thought I'd report.

comment:8 Changed 9 years ago by diekhans (Mark Diekhans)

Cc: markd@… added

Cc Me!

comment:9 Changed 9 years ago by diekhans (Mark Diekhans)

Cc: markd@… removed

Cc Me!

comment:10 Changed 9 years ago by diekhans (Mark Diekhans)

Cc: markd@… added

Cc Me!

comment:11 Changed 9 years ago by diekhans (Mark Diekhans)

Cc: markd@… removed

Cc Me!

comment:12 Changed 8 years ago by diekhans (Mark Diekhans)

Cc: markd@… added

Cc Me!

comment:13 in reply to:  1 ; Changed 8 years ago by cooljeanius (Eric Gallager)

Replying to ryandesign@…:

Ok, this is the issue where clang does not work as a C preprocessor for imake...

...which apparently has a fix in #42547, so that might fix this, as well...

comment:14 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:15 Changed 8 years ago by mf2k (Frank Schima)

Cc: macsforever2000@… removed

comment:16 Changed 8 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:17 in reply to:  13 ; Changed 7 months ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Replying to cooljeanius:

Replying to ryandesign@…:

Ok, this is the issue where clang does not work as a C preprocessor for imake...

...which apparently has a fix in #42547, so that might fix this, as well...

Yes!

comment:18 in reply to:  17 Changed 7 months ago by cooljeanius (Eric Gallager)

Replying to ryandesign:

Replying to cooljeanius:

Replying to ryandesign@…:

Ok, this is the issue where clang does not work as a C preprocessor for imake...

...which apparently has a fix in #42547, so that might fix this, as well...

Yes!

Now I get a different error when trying to build magicpoint, though:

Executing:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_magicpoint/magicpoint/work/magicpoint-1.13a" && /usr/bin/make -j1 -w all EXTRA_LIBRARIES=-L/opt/local/lib 
DEBUG: system:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_magicpoint/magicpoint/work/magicpoint-1.13a" && /usr/bin/make -j1 -w all EXTRA_LIBRARIES=-L/opt/local/lib 
make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_magicpoint/magicpoint/work/magicpoint-1.13a'
/usr/bin/cc -o ./ctlwords ./ctlwords.c
./ctlwords.c:28:1: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
main(int argc, char *argv[])
^
./ctlwords.c:40:24: error: implicitly declaring library function 'isalnum' with type 'int (int)' [-Werror,-Wimplicit-function-declaration]
                                for (q = p; *q && (isalnum(*q) || *q=='_'); q++)
                                                   ^
./ctlwords.c:40:24: note: include the header <ctype.h> or explicitly provide a declaration for 'isalnum'
./ctlwords.c:47:2: error: implicitly declaring library function 'exit' with type 'void (int) __attribute__((noreturn))' [-Werror,-Wimplicit-function-declaration]
        exit(0);
        ^
./ctlwords.c:47:2: note: include the header <stdlib.h> or explicitly provide a declaration for 'exit'
1 warning and 2 errors generated.
make: *** [ctlwords.h] Error 1
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_magicpoint/magicpoint/work/magicpoint-1.13a'
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_magicpoint/magicpoint/work/magicpoint-1.13a" && /usr/bin/make -j1 -w all EXTRA_LIBRARIES=-L/opt/local/lib 
Exit code: 2
Error: Failed to build magicpoint: command execution failed
DEBUG: Error code: CHILDSTATUS 30155 2
Note: See TracTickets for help on using tickets.