Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#41611 closed defect (duplicate)

wine @1.6.1: configure fails

Reported by: bitaminn@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: wine

Description (last modified by ryandesign (Ryan Schmidt))

Reading a guide to install wine via macports, for gaming purposes, anyway, i was told to enter "sudo port install wine" into my terminal, and i did. After about maybe an hour and a half/two hours of installing/downloading patches, ect. it gave me this error... so i decided to quit terminal and try again and this time in seconds it gave me the same error without reinstalling all the other stuff with it, im not really sure if thats normal, and im guessing its because it already knows ive downloaded the rest of that stuff, but anyway I'm just looking for a way to resolve this and download wine because for some reason my bootcamp windows doesn't respond well with my bluetooth keyboard so its nearly impossible to play that way. Thanks, Max.

--->  Computing dependencies for wine
--->  Configuring wine
Error: Failed to configure wine, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_wine/wine/work/wine-1.6.1/config.log
Error: org.macports.configure for port wine returned: configure failure: command execution failed
Please see the log file for port wine for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_wine/wine/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port wine failed

Attachments (1)

main.log (170.1 KB) - added by bitaminn@… 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Keywords: Error: Failed to configure wine removed
Port: wine added
Resolution: duplicate
Status: newclosed
Summary: Trying to install Winewine @1.6.1: configure fails
Type: requestdefect

You did not attach the main.log file or the config.log file, so I don't know exactly what went wrong, but I assume this is a duplicate of #41605 since all users who build from source (which you clearly are) should be experiencing this issue.

Changed 7 years ago by bitaminn@…

Attachment: main.log added

comment:2 in reply to:  1 Changed 7 years ago by bitaminn@…

Replying to ryandesign@…:

You did not attach the main.log file or the config.log file, so I don't know exactly what went wrong, but I assume this is a duplicate of #41605 since all users who build from source (which you clearly are) should be experiencing this issue.

I attached the log file, hope you can help. Thanks

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

That confirms it's a duplicate of the ticket I mentioned above, which I'm working on.

If you want an immediate fix, you can use the wine-devel port, which I already fixed. This will get you a slightly newer (development) version of wine, instead of the stable version.

comment:4 Changed 7 years ago by bitaminn@…

Would i need to uninstall anything from trying that first install?

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

You need to selfupdate to get the fix:

sudo port selfupdate

If you have already installed a previous version of the wine port, you would need to deactivate it:

sudo port -f deactivate wine

Otherwise you can proceed to installing wine-devel:

sudo port install wine-devel

comment:6 Changed 7 years ago by bitaminn@…

so youre saying to fix the version i tried to install, self update?

comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt)

"sudo port selfupdate" will download all committed fixes for all ports. I have committed a fix for wine-devel within the past two hours. I am still working on the fix for wine.

comment:8 Changed 7 years ago by bitaminn@…

oh gotcha.. sorry im not to savvy with these types of things. i already did the update, now im installing the development version, ill let you know how it goes and if it works with what i need it to work with

comment:9 Changed 7 years ago by bitaminn@…

like i said, im pretty new to os x and i understand what wine does, but i dont really understand anything beyond that... is it something that just runs in the background? or is it an actual app? last thing it told me was "no broken files found" so i'm assuming its installed?

comment:10 Changed 7 years ago by ryandesign (Ryan Schmidt)

Sounds like it's installed.

Wine is a program for OS X and Linux that lets you run some Windows programs. If you need further help using wine, type "port gohome wine-devel" and read their documentation.

comment:11 Changed 7 years ago by bitaminn@…

thanks a bunch man, you've been a great help

comment:12 Changed 7 years ago by bitaminn@…

This is a bit off topic... but i installed my game, via wine... now the next part of this guide says

Now, to get your game up and actually running, you’ll need to launch Terminal one final time. Type the following into Terminal to get to your Program Files folder:

cd ~/.wine/drive_c/Program\ Files/

Then type

ls

This should show you the name of the game you installed; head into the folder with a cd command. In that game folder should (finally) be a file that starts the game, ending in .exe – this is your game file. Type the following into Terminal to > get it running:

wine PROGRAM.exe

It will let me get to the program files... it says...

cd ~/.wine/drive_c/Program\ Files/
max-pc:Program Files Max$ ls
Common Files		Electronic Arts		Internet Explorer

i assume my game file is in the EA folder.. but i'm not sure hpw to get in there to see what my file is called to run it.

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:13 Changed 7 years ago by ryandesign (Ryan Schmidt)

I have fixed your WikiFormatting above.

Sounds like you just need to find a basic tutorial about how a shell works. To get you started, cd means "change directory", and ls means "list". So, if you're currently in the Program Files directory, and you want to see what's in the Electronic Arts subdirectory thereof, you could either type:

ls "Electronic Arts"

or:

ls Electronic\ Arts

or:

cd "Electronic Arts"
ls

And so on. You can also type open to open the directory in the Finder, if you're more comfortable navigating your filesystem in the Finder than in the shell.

As you've already said above, this is off-topic. Our issue tracker is for bug reports and feature requests, not for technical support. If you need help using MacPorts, write to the macports-users mailing list. If you need help with wine, ask in a wine support forum. If you need help using the shell, look for a book or tutorial on Google.

comment:14 Changed 7 years ago by bitaminn@…

thank you again and it appears that the version of wine you had me install is working just fine...

Note: See TracTickets for help on using tickets.