Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#41645 closed defect (fixed)

freetype: crash in TT_Load_Simple_Glyph

Reported by: nortcele Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: takanori@…, Martin.vGagern@…, atlantide84@…, chuiyewleong@…
Port: freetype

Description (last modified by ci42)

With a MacBook pro, OS X Mavericks, Xcode 5.02, MacPorts 2.2.1. All ports uninstalled.

Installation of port urw-fonts fails the first time, then succeed.

Here are MacPort messages during installations of failed installation.

--->  Fetching archive for urw-fonts
--->  Attempting to fetch urw-fonts-1.0.7pre44_0.darwin_13.noarch.tbz2 from http://lil.fr.packages.macports.org/urw-fonts
--->  Attempting to fetch urw-fonts-1.0.7pre44_0.darwin_13.noarch.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/urw-fonts
--->  Attempting to fetch urw-fonts-1.0.7pre44_0.darwin_13.noarch.tbz2 from http://packages.macports.org/urw-fonts
--->  Fetching distfiles for urw-fonts
--->  Verifying checksums for urw-fonts
--->  Extracting urw-fonts
--->  Configuring urw-fonts
--->  Building urw-fonts
--->  Staging urw-fonts into destroot
--->  Installing urw-fonts @1.0.7pre44_0
--->  Activating urw-fonts @1.0.7pre44_0
Error: org.macports.activate for port urw-fonts returned: 
Please see the log file for port urw-fonts for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_urw-fonts/urw-fonts/main.log

I attached the corresponding log.

Attachments (3)

urw-fonts-install-main.log (112.0 KB) - added by nortcele 6 years ago.
dejavu-fonts-install-main.log (51.5 KB) - added by nortcele 6 years ago.
port_install_urw-font_debug.zip (76.3 KB) - added by nortcele 6 years ago.

Download all attachments as: .zip

Change History (21)

Changed 6 years ago by nortcele

Attachment: urw-fonts-install-main.log added

comment:1 Changed 6 years ago by ci42

Cc: takanori removed
Description: modified (diff)
Owner: changed from macports-tickets@… to takanori@…

In the future please use WikiFormatting. Note that the Cc field requires a full email address.

comment:2 Changed 6 years ago by nortcele

Perhaps the error is not in the urn-font port installation. I have a similar error with the installation of dejavu-fonts @2.34_0 that fails with:

--->  Fetching archive for dejavu-fonts
--->  Attempting to fetch dejavu-fonts-2.34_0.darwin_13.noarch.tbz2 from http://lil.fr.packages.macports.org/dejavu-fonts
--->  Attempting to fetch dejavu-fonts-2.34_0.darwin_13.noarch.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/dejavu-fonts
--->  Attempting to fetch dejavu-fonts-2.34_0.darwin_13.noarch.tbz2 from http://packages.macports.org/dejavu-fonts
--->  Fetching distfiles for dejavu-fonts
--->  Verifying checksums for dejavu-fonts
--->  Extracting dejavu-fonts
--->  Configuring dejavu-fonts
--->  Building dejavu-fonts
--->  Staging dejavu-fonts into destroot
--->  Installing dejavu-fonts @2.34_0
--->  Activating dejavu-fonts @2.34_0
Error: org.macports.activate for port dejavu-fonts returned: 
Error: Failed to install dejavu-fonts
Please see the log file for port dejavu-fonts for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_dejavu-fonts/dejavu-fonts/main.log

(log attached)

Fonts appear to be installed but the activation fails. If after the failure, I "sudo install dejavu-fonts", then the installation ends correctly.

Perhaps is it due to the way Mavericks manage SSD disk. I don't have any idea to find what is the true source of the failure.

Last edited 6 years ago by nortcele (previous) (diff)

Changed 6 years ago by nortcele

comment:3 Changed 6 years ago by nortcele

I installed these ports without problem on the following configuration: Mac mini server (late 2012), Intel Core i7 2.6 GHz, 2 classical 1 Tb Hard disks, OS X 10.8.5 - Xcode 5.02, MacPorts 2.2.1. All ports uninstalled.

Last edited 6 years ago by nortcele (previous) (diff)

comment:4 Changed 6 years ago by nortcele

I made another successful installation of these ports on the following configuration: iMac 21.5" (late 2009), Intel Core 2 duo 3.06 GHz, classical 500 Mb Hard disk, 0S X 10.9 Mavericks - Xcode 5.02, MacPorts 2.2.1. All ports uninstalled.

So the problem seems to be related to the MacBook Pro where the installation fails.

comment:5 Changed 6 years ago by nortcele

After more tests I think that the problem is with fc-cache from the fontconfig port. After an installation with

sudo port -d install urw-fonts > Desktop/port_install_urw-font_debug.log 2>&1

I have 3 fc-cache crash reports. 3 crashes are visible in the macports log:

sh: line 1: 90529 Segmentation fault: 11  /opt/local/bin/fc-cache -frsv
sh: line 1: 90532 Segmentation fault: 11  /opt/local/bin/fc-cache -frv

The third one is not catched by macports.

The port_install_urw-font_debug.zip archive contains the output of the installation and the 3 crash reports.

Last edited 6 years ago by nortcele (previous) (diff)

Changed 6 years ago by nortcele

comment:6 Changed 6 years ago by takanori@…

Keywords: fc-cache added

Which version of freetype are you using?

freetype was updated from @2.5.0_1 to @2.5.1_0 recently. Maybe it makes fc-cache unstable, I guess.

Last edited 6 years ago by takanori@… (previous) (diff)

comment:7 Changed 6 years ago by takanori@…

Cc: takanori@… added
Owner: changed from takanori@… to ryandesign@…
Port: fontconfig added; urw-font removed
Summary: urw-fonts @1.0.7pre44_0 install failurefontconfig: fc-cache fails due to signal 11 during font installation

Anyway, I suppose that this is fontconfig's issue.

comment:8 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: Martin.vGagern@… added
Keywords: fc-cache removed
Port: freetyep added
Summary: fontconfig: fc-cache fails due to signal 11 during font installationfontconfig, freetype: fc-cache and fc-list crash

Has duplicate #41655.

freetype was recently updated; perhaps fontconfig needs to be rebuilt against the new freetype. Please try rebuilding fontconfig and let me know if that fixes the crash:

sudo port clean fontconfig
sudo port -ns upgrade --force fontconfig

If it does not, please report the problem to the developers. Since the crashing programs are fontconfig programs, I'd start by reporting it to them.

comment:9 in reply to:  6 Changed 6 years ago by nortcele

Replying to takanori@…:

Which version of freetype are you using?

freetype was updated from @2.5.0_1 to @2.5.1_0 recently. Maybe it makes fc-cache unstable, I guess.

Before the tests I remove all installed ports so I use the last version available. @2.5.1 this morning.

comment:10 in reply to:  8 Changed 6 years ago by nortcele

Replying to ryandesign@…:

Has duplicate #41655.

freetype was recently updated; perhaps fontconfig needs to be rebuilt against the new freetype. Please try rebuilding fontconfig and let me know if that fixes the crash:

sudo port clean fontconfig
sudo port -ns upgrade --force fontconfig

If it does not, please report the problem to the developers. Since the crashing programs are fontconfig programs, I'd start by reporting it to them.

Sadly, that doesn't fixe the crashes.

comment:11 Changed 6 years ago by ryandesign (Ryan Schmidt)

Other tickets mentioning similar fontconfig and freetype symbols: #41651 (emacs), #41599 (inkscape).

Last edited 6 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:12 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: atlantide84@… added
Port: freetype added; fontconfig freetyep removed
Status: newassigned
Summary: fontconfig, freetype: fc-cache and fc-list crashfreetype: crash in TT_Load_Simple_Glyph

Same crash in #41671 (gftp-gtk, wine and other gtk-based programs).

Last edited 6 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:13 Changed 6 years ago by ryandesign (Ryan Schmidt)

Submitted bug report to freetype: https://savannah.nongnu.org/bugs/index.php?40797

comment:14 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: chuiyewleong@… added

Has duplicate #41674 (with graphviz' dot while building gnuradio)

comment:15 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

I was able to reproduce the issue using fc-list. Upstream fixed this a couple days ago; I applied their fix to our port in r114266. Now fc-list works fine so I think this fixes the problem.

comment:16 in reply to:  15 Changed 6 years ago by atlantide84@…

Replying to ryandesign@…:

I was able to reproduce the issue using fc-list. Upstream fixed this a couple days ago; I applied their fix to our port in r114266. Now fc-list works fine so I think this fixes the problem.

I just updated and now all works, no more crashes..so #41671 is fixed now. Thank you!

comment:17 Changed 6 years ago by nortcele

No more crashes here too. Thank you a lot.

comment:18 Changed 6 years ago by chuiyewleong@…

The gnuradio-companion works like a charm now. Thanks.

Note: See TracTickets for help on using tickets.