Opened 5 years ago

Closed 5 years ago

#41655 closed defect (duplicate)

fontconfig, freetype: segmentation fault loading font

Reported by: Martin.vGagern@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: fontconfig, freetype

Description

fc-list Helvetica crashes on me with a single error line mentioning Segmentation fault: 11. Running this through gdb --args I get the following backtrace:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x00000000000002b0
0x0000000100056a65 in TT_Load_Simple_Glyph ()
(gdb) bt
#0  0x0000000100056a65 in TT_Load_Simple_Glyph ()
#1  0x000000010005871c in load_truetype_glyph ()
#2  0x00000001000512a5 in tt_glyph_load ()
#3  0x0000000100042b68 in FT_Load_Glyph ()
#4  0x00000001000130de in FcFreeTypeCheckGlyph ()
#5  0x000000010001265c in FcFreeTypeCharSetAndSpacingForSize ()
#6  0x0000000100011c64 in FcFreeTypeQueryFace ()
#7  0x00000001000121d3 in FcFreeTypeQuery ()
#8  0x000000010000e9cf in FcFileScanConfig ()
#9  0x000000010000ec4a in FcDirScanConfig ()
#10 0x000000010000ed91 in FcDirCacheScan ()
#11 0x000000010000905e in FcConfigAddDirList ()
#12 0x0000000100008f83 in FcConfigBuildFonts ()
#13 0x0000000100013d26 in FcInitLoadOwnConfigAndFonts ()
#14 0x0000000100008830 in FcConfigEnsure ()
#15 0x0000000100013d91 in FcInitBringUptoDate ()
#16 0x00000001000160d2 in FcFontList ()
#17 0x00000001000019bb in main ()

Trying to associate the above function list to ports installing the corresponding libraries, I obtained the following list (which might be incomplete):

The following ports are currently installed:
  fontconfig @2.11.0_0 (active)
  freetype @2.5.1_0 (active)

Originally I found this problem with graphviz dot, but this approach via fc-list should be much easier to reproduce and diagnose.

Change History (3)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to ryandesign@…

In the future, please Cc the port maintainers (port info --maintainers freetype).

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

fc-list Helvetica does not crash on my system.

Crashes are usually bugs in the upstream software; please report the problem to the developers so they can look into it.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Port: fontconfig added
Resolution: duplicate
Status: newclosed
Summary: segmentation fault loading fontfontconfig, freetype: segmentation fault loading font

Duplicate of #41645.

Note: See TracTickets for help on using tickets.