Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#41657 closed defect (fixed)

py27-llvmpy: checksum mismatch

Reported by: carlossalvadorbilardo@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: stromnov (Andrew Stromnov)
Port: py27-llvmpy

Description (last modified by ryandesign (Ryan Schmidt))

I am running macports over Mavericks. I have installed several modules thus far, but I am stuck with py-numba that won't install. The full log is:

 vi /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-llvmpy/py27-llvmpy/main.log

version:1
:debug:clean Attempting ln -sf /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-llvmpy/py27-llvmpy/work /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/python/py-llvmpy/work
:debug:clean changing euid/egid - current euid: 0 - current egid: 0
:debug:clean egid changed to: 501
:debug:clean euid changed to: 502
:debug:main Executing org.macports.main (py27-llvmpy)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.archivefetch (py27-llvmpy)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (py27-llvmpy)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:checksum checksum phase started at Mon Dec  2 18:11:21 ART 2013
:notice:checksum --->  Verifying checksums for py27-llvmpy
:debug:checksum Executing org.macports.checksum (py27-llvmpy)
:info:checksum --->  Checksumming llvmpy-0.12.1.tar.gz
:error:checksum Checksum (rmd160) mismatch for llvmpy-0.12.1.tar.gz
:info:checksum Portfile checksum: llvmpy-0.12.1.tar.gz rmd160 0b64f5cff1fe5d0240adc97b0e572c5946e99a38
:info:checksum Distfile checksum: llvmpy-0.12.1.tar.gz rmd160 84e129abad2be9652c790c60e4846188dd939460
:error:checksum Checksum (sha256) mismatch for llvmpy-0.12.1.tar.gz
:info:checksum Portfile checksum: llvmpy-0.12.1.tar.gz sha256 994369fb17f2b153d3ceb3b7e07ff3047195cdb7fb127dd6fc55492896aafeae
:info:checksum Distfile checksum: llvmpy-0.12.1.tar.gz sha256 29d1ffc3092cf29629bb966d01616099dbc7dfed0f8a6b571eb5786f53be5d08
:info:checksum The correct checksum line may be:
:info:checksum checksums           rmd160  84e129abad2be9652c790c60e4846188dd939460 \
                    sha256  29d1ffc3092cf29629bb966d01616099dbc7dfed0f8a6b571eb5786f53be5d08
:error:checksum org.macports.checksum for port py27-llvmpy returned: Unable to verify file checksums
:debug:checksum Error code: NONE
:debug:checksum Backtrace: Unable to verify file checksums
    while executing
"$procedure $targetname"
:info:checksum Warning: targets not executed for py27-llvmpy: org.macports.activate org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
:error:checksum Failed to install py27-llvmpy
:debug:checksum can not find channel named "debuglog"
    while executing
"tcl::puts debuglog {DEBUG: Starting logging for py27-llvmpy}"
    invoked from within
"catch "tcl::puts $args""
:notice:checksum Please see the log file for port py27-llvmpy for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-llvmpy/py27-llvmpy/main.log
~      

Attachments (2)

main.log (8.0 KB) - added by carlossalvadorbilardo@… 7 years ago.
install log for py-llvmpy
main.2.log (25.0 KB) - added by carlossalvadorbilardo@… 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by carlossalvadorbilardo@…

Cc: carlossalvadorbilardo@… added

Cc Me!

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: stromnov@… added; carlossalvadorbilardo@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned
Summary: can't install py-numba, checksum in py27-llvmpy failspy27-llvmpy: checksum mismatch

Confirmed.

The difference between the tarball we mirrored before and the tarball available at github now is:

$ diff -ru llvmpy-llvmpy-6cb4b72 0.12.1_1/llvmpy-llvmpy-6cb4b72
diff -ru llvmpy-llvmpy-6cb4b72/llvm/_version.py 0.12.1_1/llvmpy-llvmpy-6cb4b72/llvm/_version.py
--- llvmpy-llvmpy-6cb4b72/llvm/_version.py	2013-11-11 15:22:39.000000000 -0600
+++ 0.12.1_1/llvmpy-llvmpy-6cb4b72/llvm/_version.py	2013-11-11 15:22:39.000000000 -0600
@@ -10,7 +10,7 @@
 # versioneer-0.7+ (https://github.com/warner/python-versioneer)
 
 # these strings will be replaced by git during git-archive
-git_refnames = " (HEAD, tag: 0.12.1, master)"
+git_refnames = " (tag: 0.12.1)"
 git_full = "fb3b6a3674a07ecb7e6bf9d5f894b8f9dbeb2761"
 GIT = "git"
 

I don't understand why this change occurred, but it seems to be pretty pointless for us and that we don't need to bring it into MacPorts. So let's just stop fetching from upstream until next version.

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Fixed in r114217. Please wait 30 minutes, then run "sudo port clean --all py27-llvmpy" and "sudo port selfupdate" and then try again.

Changed 7 years ago by carlossalvadorbilardo@…

Attachment: main.log added

install log for py-llvmpy

comment:4 Changed 7 years ago by carlossalvadorbilardo@…

Hi there,

thanks for the help. Something else seems to be failing now. I am sorry if I should open a new ticket, please excuse my lack of etiquete. The install fails. The main.log is attached. The relevant line seems to be

:debug:build couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory

I have version tcl8.6 installed according to port installed tcl and I did find the following file in my directory "/opt/local/lib/tcl8.6/tclIndex".

Cheers, Carlos

comment:5 Changed 7 years ago by carlossalvadorbilardo@…

Resolution: fixed
Status: closedreopened

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

The tclIndex error is a red herring. Please do open a new ticket if you are having a problem other than the checksum mismatch in the py27-llvmpy port.

comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

No, wait, I see the problem, and it's my fault.

comment:8 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Sometimes the github portgroup is too clever for its own good. It has a special behavior (renaming the source directory) if the master_sites are github's; by changing the master_sites in r114217 I disabled that behavior, which we still want. Fixed in r114222.

comment:9 Changed 7 years ago by carlossalvadorbilardo@…

Resolution: fixed
Status: closedreopened

Me again. Some problem persits and another file is missing in the port install:

--->  Extracting py-llvmpy
DEBUG: Executing org.macports.extract (py-llvmpy)
DEBUG: Executing proc-post-org.macports.extract-extract-0
DEBUG: Executing proc-post-org.macports.extract-extract-1
Error: org.macports.extract for port py-llvmpy returned: no files matched glob pattern "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-llvmpy/py-llvmpy/work/*"
DEBUG: Error code: NONE
DEBUG: Backtrace: no files matched glob pattern "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-llvmpy/py-llvmpy/work/*"
    while executing
"$post $targetname"
Warning: targets not executed for py-llvmpy: org.macports.activate org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install

(attaching complete log)

Changed 7 years ago by carlossalvadorbilardo@…

Attachment: main.2.log added

comment:10 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

I'm doing well today... should be fixed in r114224.

comment:11 Changed 7 years ago by carlossalvadorbilardo@…

Worked!!! Many thanks.

Note: See TracTickets for help on using tickets.