Opened 6 years ago

Closed 6 years ago

#41779 closed defect (fixed)

hs-aeson @0.6.2.1_1 configure failure: command execution failed

Reported by: Superlokkus (Markus Klemm) Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: hs-aeson

Description

---> Configuring hs-aeson Error: org.macports.configure for port hs-aeson returned: configure failure: command execution failed

:info:configure Configuring aeson-0.6.2.1...
:info:configure Setup: At least the following dependencies are missing:
:info:configure attoparsec >=0.8.6.1

Attachments (2)

main.log (7.7 KB) - added by Superlokkus (Markus Klemm) 6 years ago.
ghcpkg_putput.txt (17.5 KB) - added by Superlokkus (Markus Klemm) 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Superlokkus (Markus Klemm)

Attachment: main.log added

comment:1 Changed 6 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to cal@…
Status: newassigned

I think hs-attoparsec and its dependents might need a revbump. Can you attach the output of ghc-pkg check and ghc-pkg list, please?

Last edited 6 years ago by neverpanic (Clemens Lang) (previous) (diff)

Changed 6 years ago by Superlokkus (Markus Klemm)

Attachment: ghcpkg_putput.txt added

comment:2 in reply to:  1 Changed 6 years ago by Superlokkus (Markus Klemm)

Replying to cal@…:

I think hs-attoparsec and its dependents might need a revbump. Can you attach the output of ghc-pkg check and ghc-pkg list, please?

Done, see attachments.

comment:3 Changed 6 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: assignedclosed

For each package that you have twice in the output of ghc-pkg list, please run sudo ghc-pkg unregister $name-$version where $name is the package name and $version is the older version of the package.

In your case that's

  • highlighting-kate-0.5.3.9 and
  • binary-0.5.1.1

These problems are caused by a bug in the haskell PortGroup which previously wouldn't successfully remove packages from the list while uninstalling them from MacPorts when there were still other (haskell) packages using them. This bug has since been fixed, but I cannot automatically fix that for packages that have been broken by it.

I've revbumped hs-attoparsec and its dependencies in r114665. That might or might not have been necessary, but since I have done lots of incorrect updates for haskell ports some unneeded revbumps probably don't hurt anyone to come back to a consistent state (especially since the buildbots will produce packages for those).

I think this problem should be fixed. Please re-open if you still encounter it.

Note: See TracTickets for help on using tickets.