Opened 6 years ago

Closed 4 years ago

#41861 closed update (fixed)

Terminal: update to 0.6.3 and rename to xfce4-terminal

Reported by: ryandesign (Ryan Schmidt) Owned by: afb@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: cooljeanius (Eric Gallager), dbevans (David B. Evans), vnebel@…, rudloff@…, diekhans (Mark Diekhans)
Port: Terminal xfce4-terminal

Description (last modified by dbevans (David B. Evans))

In version 0.6, Terminal has been renamed upstream to xfce4-terminal. Version 0.6.3 is now available. The NEWS file says as of 0.6 the exo dependency was updated to version 0.10 (see #41860 requesting this update), but also that the exo dependency was dropped; not sure which is correct. The NEWS file also says that libxfce4ui is now a dependency. We don't have a port by that name, but we do have libxfcegui4; not sure if that's what they mean.

Attached are two patches. To apply them, first:

cd $(port dir Terminal)/..
svn rm Terminal/files
svn copy Terminal xfce4-terminal

Then apply xfce4-termanal.diff to the xfce4-terminal Portfile to update it to 0.6.3, and apply Terminal.diff to the Terminal Portfile to make it replaced_by xfce4-terminal.

More changes may be necessary. I have not tested this patch because it still fails as in #41379.

Attachments (4)

Terminal.diff (1.2 KB) - added by ryandesign (Ryan Schmidt) 6 years ago.
patch for Terminal port to make it replaced_by xfce4-terminal
xfce4-terminal.diff (1.5 KB) - added by ryandesign (Ryan Schmidt) 6 years ago.
patch for xfce4-terminal port to update it to 0.6.2
xfce4-terminal.2.diff (1.8 KB) - added by dbevans (David B. Evans) 6 years ago.
Revised patch to update to current version 0.6.3.
xfce4-terminal.3.diff (2.6 KB) - added by dbevans (David B. Evans) 6 years ago.
Further revision of patch to depend on vte-gtk2-compat.

Download all attachments as: .zip

Change History (14)

Changed 6 years ago by ryandesign (Ryan Schmidt)

Attachment: Terminal.diff added

patch for Terminal port to make it replaced_by xfce4-terminal

Changed 6 years ago by ryandesign (Ryan Schmidt)

Attachment: xfce4-terminal.diff added

patch for xfce4-terminal port to update it to 0.6.2

comment:1 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Changed 6 years ago by dbevans (David B. Evans)

Attachment: xfce4-terminal.2.diff added

Revised patch to update to current version 0.6.3.

comment:2 Changed 6 years ago by dbevans (David B. Evans)

Cc: devans@… added
Description: modified (diff)
Summary: Terminal: update to 0.6.2 and rename to xfce4-terminalTerminal: update to 0.6.3 and rename to xfce4-terminal
Version: 2.2.1

Revised patch attached to update to the current version 0.6.3 and fixes livecheck which previously relied on the freecode fallback default. Still fails to configure with the current version of vte.

comment:3 in reply to:  2 ; Changed 6 years ago by cooljeanius (Eric Gallager)

Replying to devans@…:

Still fails to configure with the current version of vte.

The old version of vte installs in parallel with the current version of vte; would it make sense for trunk to have a separate port for the old vte? I mean, that's what I do locally, just wondering if it would make sense here as well...

comment:4 in reply to:  3 Changed 6 years ago by dbevans (David B. Evans)

Replying to egall@…:

Replying to devans@…:

Still fails to configure with the current version of vte.

The old version of vte installs in parallel with the current version of vte; would it make sense for trunk to have a separate port for the old vte? I mean, that's what I do locally, just wondering if it would make sense here as well...

Yes, I'm already working on this.

comment:5 Changed 6 years ago by dbevans (David B. Evans)

New port vte-gtk2-compat, based on vte 0.28.2, committed in r122208. This port installs in parallel with the current gtk3 compatible version of vte and satisfies the vte requirements of this port.

Changed 6 years ago by dbevans (David B. Evans)

Attachment: xfce4-terminal.3.diff added

Further revision of patch to depend on vte-gtk2-compat.

comment:6 Changed 6 years ago by dbevans (David B. Evans)

Patch attached to depend on vte-gtk2-compat. This addresses the vte issue in configure but then a new issue arises in its place.

:info:configure checking for pkg-config... (cached) /opt/local/bin/pkg-config
:info:configure checking pkg-config is at least version 0.9.0... yes
:info:configure checking for vte >= 0.28... 0.28.2
:info:configure checking VTE_CFLAGS... -D_REENTRANT -I/opt/local/include/vte-0.0 -I/opt/local/include/gtk-2.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/pango-1.0 -I/opt/local/include -I/opt/local/include/atk-1.0 -I/opt/local/include/gdk-pixbuf-2.0 -I/opt/local/include/libpng16 -I/opt/local/include/pango-1.0 -I/opt/local/include/harfbuzz -I/opt/local/include/pango-1.0 -I/opt/local/include/gio-unix-2.0/ -I/opt/local/include/cairo -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/pixman-1 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/libpng16 -I/opt/local/include
:info:configure checking VTE_LIBS... -L/opt/local/lib -lvte -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lXfixes -latk-1.0 -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lpango-1.0 -lm -lfontconfig -lfreetype -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lintl -lcairo -lX11 -lXext
:info:configure checking for pkg-config... (cached) /opt/local/bin/pkg-config
:info:configure checking pkg-config is at least version 0.9.0... yes
:info:configure checking for gio-2.0 >= 2.26.0... 2.40.0
:info:configure checking GIO_CFLAGS... -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include
:info:configure checking GIO_LIBS... -L/opt/local/lib -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lintl
:info:configure checking for pkg-config... (cached) /opt/local/bin/pkg-config
:info:configure checking pkg-config is at least version 0.9.0... yes
:info:configure checking for libxfce4ui-1 >= 4.10.0... not found
:info:configure *** The required package libxfce4ui-1 was not found on your system.
:info:configure *** Please install libxfce4ui-1 (atleast version 4.10.0) or adjust
:info:configure *** the PKG_CONFIG_PATH environment variable if you
:info:configure *** installed the package in a nonstandard prefix so that
:info:configure *** pkg-config is able to find it.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_Users_devans_macports_dports_xfce_xfce4-terminal/xfce4-terminal/work/xfce4-termin
al-0.6.3" && ./configure --prefix=/opt/local
:info:configure Exit code: 1

It appears that this version of xfce4-terminal requires the xfce libraries to be updated to version 4.10.0. In particular, libxfcegui4 needs to be updated to version 4.10.0 which is now renamed to libxfce4ui. See #44363.

comment:7 Changed 6 years ago by dbevans (David B. Evans)

Cc: vnebel@… rudloff@… markd@… added

Ticket #41379 closed as duplicate of this one. Reporter and CC's of that ticket added here for information.

comment:8 Changed 6 years ago by afb@…

Already covered by #31203

comment:9 Changed 6 years ago by afb@…

Status: newassigned

comment:10 Changed 4 years ago by afb@…

Resolution: fixed
Status: assignedclosed

Fixed, r144133.

Note: See TracTickets for help on using tickets.