Opened 7 years ago

Closed 7 years ago

#41888 closed defect (duplicate)

Failed to build openjpeg

Reported by: papachoco (Carlos Sanchez) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: openjpeg

Description

openjpeg fails to build under OS X 10.9.1 and xcode 5.0.2 .. Log attached

Attachments (1)

main.log (161.7 KB) - added by papachoco (Carlos Sanchez) 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by papachoco (Carlos Sanchez)

Attachment: main.log added

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; mcalhoun@… removed
Keywords: Build failure removed
Milestone: MacPorts Future
Owner: changed from macports-tickets@… to mcalhoun@…

It builds fine for me on my Mavericks machine, which runs MacPorts trunk and additional patches, but I saw the same failure on another machine which was running an earlier OS X and MacPorts 2.2.1.

Does it help if you deactivate the old openjpeg first?

sudo port clean openjpeg
sudo port -f deactivate openjpeg
sudo port upgrade openjpeg

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Carlos responded by email:

I removed the port when the upgrade failed and it still fails trying to install it anew

Duplicate of #41216.

Note: See TracTickets for help on using tickets.