Opened 7 years ago

Last modified 7 years ago

#41894 new defect

Build of autotrace 0.31.1_9 does not detect installed pstoedit

Reported by: ballapete (Peter Dyballa) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cooljeanius (Eric Gallager)
Port: autotrace

Description

This happens:

*** Checking pstoedit existence TWICE(if needed) ***
*** This is the 1st check                        ***
checking for pstoedit-config... /opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_graphics_autotrace/autotrace/work/bin/pstoedit-config
checking for PSTOEDIT - version >= 3.32.1... no
*** Could not run PSTOEDIT test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding PSTOEDIT or finding the wrong
*** version of PSTOEDIT. If it is not finding PSTOEDIT, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location  Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
*** The 1st check is failed.                     ***
*** This is the 2nd check                        ***
checking for pstoedit-config... (cached) /opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_graphics_autotrace/autotrace/work/bin/pstoedit-config
checking for PSTOEDIT - version >= 3.32.0... no
*** Could not run PSTOEDIT test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding PSTOEDIT or finding the wrong
*** version of PSTOEDIT. If it is not finding PSTOEDIT, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location  Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
*** The 2nd check is failed.                     ***
configure: WARNING:
*** Cannot find libpstoedit. ***
*** Output functions using libpstoedit are disabled ***
configure: creating ./config.status
config.status: creating Makefile
config.status: creating autotrace-config
config.status: creating autotrace.pc
config.status: creating autotrace.spec
config.status: creating config.h
config.status: executing default-1 commands
config.status: executing default commands


Configuration:
	imagemagick output support:	yes
	libpng output support:		yes
	swf output support by ming:	yes
	pstoedit output support:	no

although an usable version of pstoedit is installed:

pete 297 /\ l /opt/local/lib/libpstoedit*
-rwxr-xr-x  1 root  admin  343324 22 Dez 20:59 /opt/local/lib/libpstoedit.0.dylib
lrwxrwxrwx  1 root  admin      19 22 Dez 20:59 /opt/local/lib/libpstoedit.dylib -> libpstoedit.0.dylib
-rwxr-xr-x  1 root  admin     928 22 Dez 20:59 /opt/local/lib/libpstoedit.la
pete 298 /\ port installed | grep pstoedit
  pstoedit @3.61_3
  pstoedit @3.61_4 (active)

This problem was already reported and solved in #28663. Here and now it happens on PPC Leopard (Mac OS X 10.5.8).

Change History (1)

comment:1 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.