Opened 6 years ago

Closed 6 years ago

#41903 closed defect (fixed)

Update pf qtiplot to 0.9.8.9_8 fails.

Reported by: watsodw Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: qtiplot

Description

See log.

Attachments (3)

main.log (46.8 KB) - added by watsodw 6 years ago.
update_main.log (910.8 KB) - added by watsodw 6 years ago.
new_build_main.log (121.5 KB) - added by watsodw 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by watsodw

Attachment: main.log added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: nicos@… removed
Owner: changed from macports-tickets@… to nicos@…

It installed fine for me on Mavericks, and this was not a clean build attempt. Please clean and try again.

comment:2 Changed 6 years ago by watsodw

Cleaned and tried again, but same result. I decided to uninstall it and try a fresh install, but it too failed. Attached are the log files for both attempts.

Changed 6 years ago by watsodw

Attachment: update_main.log added

Changed 6 years ago by watsodw

Attachment: new_build_main.log added

comment:3 Changed 6 years ago by NicosPavlov

There indeed seem to be some issues with the +python27 variant presently. In case you don't specifically need python scripting, one quick workaround is to build qtiplot without the python27 variant. I will look into the issue, but I am far from sure I will be able to solve this one rapidly.

comment:4 Changed 6 years ago by NicosPavlov

Resolution: fixed
Status: newclosed

It appears that the same issue was happening on Debian and Ubuntu with the newer py-sip versions, and reusing the patches from there (https://bugs.launchpad.net/ubuntu/+source/qtiplot/+bug/1243269) solved the issue. Committed in r115325.

Note: See TracTickets for help on using tickets.