Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#41927 closed update (fixed)

wxPython-3.0: upgrade to 3.0.0.0

Reported by: mojca (Mojca Miklavec) Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: jyrkiwahlstedt, michaelld (Michael Dickens), eborisch (Eric A. Borisch), neurodroid (Christoph Schmidt-Hieber)
Port: wxWidgets-3.0, wxPython-3.0, py-wxpython-3.0, grass, gnuradio, gr-fosphor, stimfit, py-robotframework-ride, py-winpdb

Description

I'm attaching a (temporary) patch for upgrading wxPython to preliminary release of version 3.0.0.0.

Please test if your ports work OK or provide any kind of other feedback.

I would also be grateful to any volunteer willing to prepare a patch for revbumps of dependents. If you plan a port upgrade anyway, you may also submit a patch to this ticket.

Attachments (1)

wxPython-3.0.0.0.diff (6.0 KB) - added by mojca (Mojca Miklavec) 5 years ago.
A patch to upgrade wxPython-3.0 to preliminary release of version 3.0.0.0

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by mojca (Mojca Miklavec)

Attachment: wxPython-3.0.0.0.diff added

A patch to upgrade wxPython-3.0 to preliminary release of version 3.0.0.0

comment:1 Changed 5 years ago by mojca (Mojca Miklavec)

I forgot to add file removals to the diff (all patches specific to version 2.9.5 should be removed from files), but since that doesn't influence the functionality and only obscures readability of the patch, I won't re-upload.

comment:2 Changed 5 years ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: newclosed
Summary: wxPython-3.0: upgrade to 3.0.0.0 (request for testing dependents)wxPython-3.0: upgrade to 3.0.0.0

Committed in r115276 (wxPython), r115277 (fix checksums), r115278 (touch to force rebuild), r115279 (dependents).

comment:3 Changed 5 years ago by mojca (Mojca Miklavec)

A special note to christsc: r115280 fixes a configuration bug that prevented stimfit from regocnising wxWidgets version 3.0.0 as greater than 2.8.0.

comment:4 in reply to:  3 Changed 5 years ago by neurodroid (Christoph Schmidt-Hieber)

Replying to mojca@…:

A special note to christsc: r115280 fixes a configuration bug that prevented stimfit from regocnising wxWidgets version 3.0.0 as greater than 2.8.0.

Thanks! Committed in r0571d95c7f7a. Will update the Portfile now.

Note: See TracTickets for help on using tickets.