Opened 7 years ago

Closed 6 years ago

#41950 closed defect (invalid)

libusb: no destroot found

Reported by: giantmolecules@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: tobypeterson, ryandesign (Ryan Schmidt)
Port: libusb

Description

Gnuradio fails to install on OSX 10.8.5 due to failed install of libusb.

Attachments (2)

terminal_response.txt (1.1 KB) - added by giantmolecules@… 7 years ago.
response from the terminal after issuing <sudo port install gnuradio +full>
libusb_log.txt (2.8 KB) - added by giantmolecules@… 7 years ago.
libusb port install logfile

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by giantmolecules@…

Attachment: terminal_response.txt added

response from the terminal after issuing <sudo port install gnuradio +full>

Changed 7 years ago by giantmolecules@…

Attachment: libusb_log.txt added

libusb port install logfile

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: toby@… ryandesign@… added
Keywords: gnuradio removed
Owner: changed from macports-tickets@… to rwilcox@…
Port: libusb added; gnuradio removed
Summary: Processing of port gnuradio failedlibusb: no destroot found
Error: org.macports.install for port libusb returned: no destroot found at: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_libusb/libusb/work/destroot

Clean libusb and try again.

sudo port clean libusb

comment:2 Changed 6 years ago by michaelld (Michael Dickens)

Cc: michaelld@… added

Cc Me!

comment:3 Changed 6 years ago by michaelld (Michael Dickens)

Cc: michaelld@… removed
Owner: changed from rwilcox@… to michaelld@…

comment:4 Changed 6 years ago by michaelld (Michael Dickens)

I just updated libusb a bunch; hopefully it works better now. If this ticket is still an issue, can you do:

sudo port clean gnuradio libusb
sudo port selfupdate

then try installing GNU Radio again. If libusb fails again, please post a new logfile & add a comment about your effort.

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

The issue was caused by not cleaning before trying again, as mentioned above.

Note: See TracTickets for help on using tickets.