Opened 5 years ago

Closed 5 years ago

#41981 closed defect (wontfix)

py32-game seems broken on 10.8.5

Reported by: mark@… Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: py-game

Description

I just did a fresh install of python3.2 and py32-game on MacOS 10.8.5. python3.2 fails to run "import pygame".

bash-3.2$ python3.2
Python 3.2.5 (default, May 19 2013, 14:25:55) 
[GCC 4.2.1 Compatible Apple Clang 4.1 ((tags/Apple/clang-421.11.66))] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import pygame
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.2/lib/python3.2/site-packages/pygame/__init__.py", line 95, in <module>
    from pygame.base import *
ImportError: dlopen(/opt/local/Library/Frameworks/Python.framework/Versions/3.2/lib/python3.2/site-packages/pygame/base.so, 2): Symbol not found: _PyCObject_AsVoidPtr
  Referenced from: /opt/local/Library/Frameworks/Python.framework/Versions/3.2/lib/python3.2/site-packages/pygame/base.so
  Expected in: flat namespace
 in /opt/local/Library/Frameworks/Python.framework/Versions/3.2/lib/python3.2/site-packages/pygame/base.so
>>>

Change History (3)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jmr@…
Port: py-game added; py32-game removed

In the future, please Cc the port maintainers (port info --maintainers py32-game).

comment:2 Changed 5 years ago by jmroot (Joshua Root)

I never actually tested this under python 3; I just added it for the reporter of #35114. If it doesn't work I guess I'd better just remove it.

comment:3 Changed 5 years ago by jmroot (Joshua Root)

Resolution: wontfix
Status: newclosed

Version 1.9.2, which is not released yet, will add support for python 3.x. Removed py32-game in r126545.

Note: See TracTickets for help on using tickets.