Opened 9 years ago

Closed 9 years ago

#42072 closed defect (duplicate)

mpd 0.18.6 doesn't have the osx output plugin

Reported by: jchauvel@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: rmstonecipher@…
Port: mpd

Description

The only plugins currently reported by mpd --version are: null, fifo, ao, openal, httpd, recorder

Attachments (1)

version_output.txt (1.5 KB) - added by jchauvel@… 9 years ago.
mpd --version output

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by jchauvel@…

Attachment: version_output.txt added

mpd --version output

comment:1 Changed 9 years ago by jchauvel@…

comment:2 Changed 9 years ago by cooljeanius (Eric Gallager)

What variants do you have mpd installed with? You can see with port installed mpd

comment:3 Changed 9 years ago by jchauvel@…

I've joined the #mpd channel on freenode and the guys there told me the osx plugin was disabled by default because it was buggy and unmaintained. I guess that makes sense but then again it was working as of recently.

At least it should be considered to make a port variant out of it.

@egall mpd @0.18.6_0+ffmpeg+mod+modplug+mpg123

Last edited 9 years ago by jchauvel@… (previous) (diff)

comment:4 Changed 9 years ago by jchauvel@…

Should be relative easy to include that variant. I just tweaked my portfile to include this on it:

variant osx description {Support for CoreAudio} {
    configure.args-append   --enable-osx
}
Last edited 9 years ago by jchauvel@… (previous) (diff)

comment:5 Changed 9 years ago by larryv (Lawrence Velázquez)

Cc: openmaintainer@… removed
Resolution: duplicate
Status: newclosed

Duplicate of #42062.

Note: See TracTickets for help on using tickets.