Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#42085 closed defect (duplicate)

[ghc-bootstrap] Error [...] HSffi.o: Premature end of data, possibly corrupt file

Reported by: KurtPfeifle (Kurt Pfeifle) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: kitchen.andy@…, neverpanic (Clemens Lang), openmaintainer@…
Port: ghc-bootstrap

Description

I'm seeing this error since a few weeks whenever I upgrade some port package:

Error parsing file /opt/local/share/ghc-bootstrap/lib/ghc-7.0.4/HSffi.o: Premature end of data, possibly corrupt file

I verified: this file indeed is only 184 Bytes long.

Hence I tried to re-install the package:

kp@mb: >  sudo port -f uninstall ghc-bootstrap

I verified: the "corrupt" file indeed is gone now.

kp@mb: >  sudo port install ghc-bootstrap
--->  Computing dependencies for ghc-bootstrap
--->  Fetching archive for ghc-bootstrap
Warning: Your DNS servers incorrectly claim to know the address of nonexistent hosts. This may cause checksum mismatches for some ports.
--->  Attempting to fetch ghc-bootstrap-7.0.4_1+gcc48.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/ghc-bootstrap
--->  Attempting to fetch ghc-bootstrap-7.0.4_1+gcc48.darwin_13.x86_64.tbz2.rmd160 from http://lil.fr.packages.macports.org/ghc-bootstrap
--->  Installing ghc-bootstrap @7.0.4_1+gcc48
--->  Activating ghc-bootstrap @7.0.4_1+gcc48
--->  Cleaning ghc-bootstrap
--->  Updating database of binaries: 100.0%
--->  Scanning binaries for linking errors: 0.1%
Warning: Error parsing file /opt/local/lib/ghc-paths-0.1.0.6/ghc-7.4.2/HSghc-paths-0.1.0.6.o: Error opening or reading file
--->  Scanning binaries for linking errors: 99.6%
Warning: Error parsing file /opt/local/share/ghc-bootstrap/lib/ghc-7.0.4/HSffi.o: Premature end of data, possibly corrupt file
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.

But as you can see, the "corrupt" file is re-installed. I tried to switch the mirror by editing /opt/local/etc/macports/sources.conf and /opt/local/etc/macports/macports.conf and running sudo port selfupdate afterwards. But this didn't change the result -- I still could see that the packages is fetched from lil.fr.packages.macports.org!

Change History (2)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

There isn't a problem. You can ignore the warning. Duplicate of #36996.

comment:2 in reply to:  1 Changed 8 years ago by cooljeanius (Eric Gallager)

Replying to ryandesign@…:

There isn't a problem. You can ignore the warning. Duplicate of #36996.

Also it should be fixed in trunk as of r115476

Note: See TracTickets for help on using tickets.