Opened 7 years ago

Closed 4 years ago

Last modified 2 years ago

#42194 closed defect (duplicate)

Undefined symbols upgrading qpdf on Lion

Reported by: JadeNB1729@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: qpdf

Description

When trying to upgrade qpdf on Lion (Mac OS X.8.5), I get the following error:

$ port -v upgrade qpdf
--->  Computing dependencies for qpdf.
--->  Building qpdf
make: Entering directory `$MACPORTS/base/var/macports/build/_${MACPORTS_WITH_UNDERSCORES}_base_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_qpdf/qpdf/work/qpdf-5.1.0'
/bin/bash ./libtool --mode=link /usr/bin/clang++ -pipe -Os -arch x86_64 -Wold-style-cast -Wall libtests/build/aes.o -o libtests/build/aes -lpcre -lz  -lqpdf -L$MACPORTS/base/lib -Wl,-headerpad_max_install_names -arch x86_64 -Llibqpdf/build
/bin/bash ./libtool --mode=link /usr/bin/clang++ -pipe -Os -arch x86_64 -Wold-style-cast -Wall libtests/build/buffer.o -o libtests/build/buffer -lpcre -lz  -lqpdf -L$MACPORTS/base/lib -Wl,-headerpad_max_install_names -arch x86_64 -Llibqpdf/build
/bin/bash ./libtool --mode=link /usr/bin/clang++ -pipe -Os -arch x86_64 -Wold-style-cast -Wall libtests/build/concatenate.o -o libtests/build/concatenate -lpcre -lz  -lqpdf -L$MACPORTS/base/lib -Wl,-headerpad_max_install_names -arch x86_64 -Llibqpdf/build
/bin/bash ./libtool --mode=link /usr/bin/clang++ -pipe -Os -arch x86_64 -Wold-style-cast -Wall libtests/build/flate.o -o libtests/build/flate -lpcre -lz  -lqpdf -L$MACPORTS/base/lib -Wl,-headerpad_max_install_names -arch x86_64 -Llibqpdf/build
libtool: link: /usr/bin/clang++ -pipe -Os -arch x86_64 -Wold-style-cast -Wall libtests/build/aes.o -o libtests/build/aes -Wl,-headerpad_max_install_names -arch x86_64  $MACPORTS/base/lib/libpcre.dylib -lz -lqpdf -L$MACPORTS/base/lib -Llibqpdf/build
libtool: link: /usr/bin/clang++ -pipe -Os -arch x86_64 -Wold-style-cast -Wall libtests/build/flate.o -o libtests/build/flate -Wl,-headerpad_max_install_names -arch x86_64  $MACPORTS/base/lib/libpcre.dylib -lz -lqpdf -L$MACPORTS/base/lib -Llibqpdf/build
libtool: link: /usr/bin/clang++ -pipe -Os -arch x86_64 -Wold-style-cast -Wall libtests/build/concatenate.o -o libtests/build/concatenate -Wl,-headerpad_max_install_names -arch x86_64  $MACPORTS/base/lib/libpcre.dylib -lz -lqpdf -L$MACPORTS/base/lib -Llibqpdf/build
libtool: link: /usr/bin/clang++ -pipe -Os -arch x86_64 -Wold-style-cast -Wall libtests/build/buffer.o -o libtests/build/buffer -Wl,-headerpad_max_install_names -arch x86_64  $MACPORTS/base/lib/libpcre.dylib -lz -lqpdf -L$MACPORTS/base/lib -Llibqpdf/build
Undefined symbols for architecture x86_64:
  "Pl_AES_PDF::disablePadding()", referenced from:
      _main in aes.o
  "Pl_AES_PDF::useZeroIV()", referenced from:
      _main in aes.o
  "Pl_AES_PDF::Pl_AES_PDF(char const*, Pipeline*, bool, unsigned char const*, unsigned int)", referenced from:
      _main in aes.o
  "QUtil::safe_fopen(char const*, char const*)", referenced from:
      _main in aes.o
Undefined symbols for architecture x86_64:
  "QUtil::safe_fopen(char const*, char const*)", referenced from:
      run(char const*) in flate.o
ld: symbol(s) not found for architecture x86_64
ld: symbol(s) not found for architecture x86_64
Undefined symbols for architecture x86_64:
Undefined symbols for architecture x86_64:
  "QUtil::unsigned_char_pointer(char const*)", referenced from:
      _main in buffer.o
ld: symbol(s) not found for architecture x86_64
  "QUtil::unsigned_char_pointer(std::string const&)", referenced from:
      _main in concatenate.o
ld: symbol(s) not found for architecture x86_64
clang: clang: clang: clang: error: error: linkerror: error: lllineiinnkr kkeerr  cceocromommm acnodm mmaanndd  ffaaiilmlfeanedaidd  fwal ewitih exit codei dtledh1  e(xuiste   w i-twcioth vd et o1 sexe eih(us ti n eev o-cva ttoc xiisee invocationoodt cno)d
e 1 (use -v to see invocation)
e 1 (use -v to see invocation)
)
make: *** [libtests/build/flate] Error 1
make: *** Waiting for unfinished jobs....
make: *** [libtests/build/buffer] Error 1
make: *** [libtests/build/aes] Error 1
make: *** [libtests/build/concatenate] Error 1
make: Leaving directory `$MACPORTS/base/var/macports/build/_${MACPORTS_WITH_UNDERSCORES}_base_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_qpdf/qpdf/work/qpdf-5.1.0'
Command failed:  cd "$MACPORTS/base/var/macports/build/_${MACPORTS_WITH_UNDERSCORES}_base_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_qpdf/qpdf/work/qpdf-5.1.0" && /usr/bin/make -j4 -w all 
Exit code: 2
Error: org.macports.build for port qpdf returned: command execution failed
Warning: targets not executed for qpdf: org.macports.install org.macports.build org.macports.destroot
Please see the log file for port qpdf for details: $MACPORTS/_${MACPORTS_WITH_UNDERSCORES}_base_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_qpdf/qpdf/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

Change History (4)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to dojo@…

In the future, please Cc the port maintainers (port info --maintainers qpdf).

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Owner: changed from dojo@… to macports-tickets@…

See #51936.

comment:3 Changed 4 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

Duplicate of #42101

comment:4 Changed 2 years ago by ryandesign (Ryan Schmidt)

In 46d610abd75f0822b675b02afaedff48a056470c/macports-ports (master):

qpdf: Don't link with old library

See: #42194

Note: See TracTickets for help on using tickets.