Opened 9 years ago

Closed 5 years ago

Last modified 5 years ago

#42396 closed enhancement (wontfix)

Install Java on Mavericks buildslave

Reported by: ryandesign (Ryan Schmidt) Owned by: admin@…
Priority: Normal Milestone:
Component: server/hosting Version:
Keywords: Cc: mf2k (Frank Schima), ci42, anddam (Andrea D'Amore)
Port:

Description

Please install Java on the Mavericks buildslave. Some ports require it.

Just running java in a Terminal window should pop up a GUI window from which you can learn how to install Java.

See also https://lists.macosforge.org/pipermail/macports-dev/2014-January/025814.html

Change History (14)

comment:1 Changed 9 years ago by larryv (Lawrence Velázquez)

I think that popup lets you install the latest Java that Apple maintained, which is Java 6. If possible, shouldn't we install Oracle’s Java 7 instead?

comment:2 Changed 9 years ago by ci42

To my knowledge java is installed on the mavericks buildbot. I asked shreeraj about https://lists.macosforge.org/pipermail/macports-dev/2014-January/025731.html the other day because the swi-prolog-devel port failed on the mavericks buildbot due to missing javac. He replied:

Christoph My attempts to install JDK got errors, however now if I run java -version it gives me an output. Can you take a look and let me know if it is ok? Shree

============ 
tennine-slave:~ local$ uname -n
tennine-slave.macports.org
tennine-slave:~ local$ java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)
tennine-slave:~ local$
===============

Afterwards swi-prolog-devel built without errors.

Regarding the swarm build (https://lists.macosforge.org/pipermail/macports-users/2014-February/034473.html) I think the problem is that the location of the javac command is not correctly determined on the mavericks buildbot (see https://build.macports.org/builders/buildports-mavericks-x86_64/builds/1498/steps/compile/logs/stdio)

/bin/sh: /System/Library/Frameworks/JavaVM.framework/bin/javac: No such file or directory

On the other buildbots as well as on my machine it is:

/System/Library/Frameworks/JavaVM.framework/Commands/javac

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Well it builds fine on my Mavericks machine with:

$ java -version
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)
Last edited 9 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:4 in reply to:  1 Changed 9 years ago by larryv (Lawrence Velázquez)

Replying to larryv@…:

I think that popup lets you install the latest Java that Apple maintained, which is Java 6.

Never mind, just saw the popup that links to Oracle's website, on OS X 10.9.1.

comment:5 in reply to:  2 Changed 9 years ago by larryv (Lawrence Velázquez)

Replying to ciserlohn@…:

On the other buildbots as well as on my machine it is:

/System/Library/Frameworks/JavaVM.framework/Commands/javac

That’s probably from the old Apple-maintained Java 6. The latest Oracle Java 7 installs javac at /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home/bin/javac.

comment:6 Changed 9 years ago by mf2k (Frank Schima)

Cc: skarulkar@… added; macsforever2000@… removed

comment:7 Changed 9 years ago by mf2k (Frank Schima)

Cc: mf2k@… added

Cc Me!

comment:8 Changed 9 years ago by wsiegrist@…

Owner: changed from wsiegrist@… to skarulkar@…

comment:9 Changed 9 years ago by ci42

Cc: ciserlohn@… added

Cc Me!

comment:10 Changed 8 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

Cc Me!

comment:11 Changed 6 years ago by ryandesign (Ryan Schmidt)

Owner: changed from skarulkar@… to admin@…
Status: newassigned

comment:12 Changed 5 years ago by raimue (Rainer Müller)

Cc: skarulkar@… removed
Resolution: wontfix
Status: assignedclosed

This ticket was filed against the old buildbot at macOS Forge. I guess it is no longer relevant for the new buildbot, so I am closing this ticket.

comment:13 Changed 5 years ago by ryandesign (Ryan Schmidt)

While it is true that I filed this ticket against the old buildbot, I haven't installed any Java on the new buildbot either, except when it was included as part of macOS.

comment:14 in reply to:  13 Changed 5 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign:

I haven't installed any Java on the new buildbot either, except when it was included as part of macOS.

See #56000.

Note: See TracTickets for help on using tickets.