Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#42399 closed defect (worksforme)

PETSc Build error on OSX 10.7.5

Reported by: s.schmidt@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: PETSc

Description

Tried to install PETSc as part of installing FEniCS/Dolfin using macports. Starting from a "clean" machine, /opt/ is empty, port is freshly installed, all tips and tricks with self updating and cleaning have been tried.

Seems that the Apple compiler runs into a segmentation fault during compilation:

:info:build clang: error: unable to execute command: Segmentation fault: 11 :info:build clang: error: clang frontend command failed due to signal (use -v to see invocation) :info:build Apple LLVM version 4.2 (clang-425.0.28) (based on LLVM 3.2svn)

Attachments (1)

main.log (120.4 KB) - added by s.schmidt@… 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by s.schmidt@…

Attachment: main.log added

comment:1 Changed 5 years ago by s.schmidt@…

Cc: s.schmidt@… added

Cc Me!

comment:2 Changed 5 years ago by seanfarley (Sean Farley)

Cc: s.schmidt@… removed
Owner: changed from macports-tickets@… to sean@…
Status: newassigned

You don't have to CC yourself, by the way. I'll start looking into this now.

comment:3 Changed 5 years ago by seanfarley (Sean Farley)

Well, damn, that is a compiler crash. First thing to test is updating Xcode and Xcode Command Line Tools. Can you do both of those and clean and retry?

$ sudo port clean petsc
$ sudo port install petsc

comment:4 Changed 5 years ago by s.schmidt@…

I am using Xcode Version 4.6.3 (4H1503) with matching command line tools. Updating either fails and is only available for OSX 10.8.4. With OSX 10.7.5, this is the latest one can get officially…

comment:5 Changed 5 years ago by seanfarley (Sean Farley)

Resolution: worksforme
Status: assignedclosed

Well, that's unfortunately. There are two options here, you can try to rebuild with a different compiler:

$ sudo port install mpich-clang34
$ sudo port install petsc

Or, if you just want FEniCS and don't care about PETSc, then you can skip the petsc option by

$ sudo port install dolfin -petsc -slepc

Other than that, you'd either have to submit a bug report to clang (though it might be fixed in a later version by now) or update your OS :-/

comment:6 Changed 5 years ago by mf2k (Frank Schima)

Keywords: Apple clang segfault removed
Note: See TracTickets for help on using tickets.