Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#42434 closed defect (fixed)

OpenJade 1.3.2 fails to build

Reported by: ksee.zelgadis@… Owned by: lockhart (Thomas Lockhart)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: adamb2903, dholl (D. Holl)
Port: openjade

Description

When I am tried to install gtkmm, it is failed when trying to build open jade. Log file is attached.

Some notes about my setup:

  • OSX 10.8.2 (64bit)
  • Xcode 4.6.3
  • Macports root is "/Users/Admin/src/macports/SynfigStudio-app/Contents/Resources"
  • The path "/Users/Admin/src/macports/SynfigStudio-app" is actually a symlink to "/tmp/skl/SynfigStudio.app"

Notice the error message mentions "/tmp/skl/SynfigStudio.lapp" instead of "/tmp/skl/SynfigStudio.app" (that's it: ".lapp" instead of ".app"). I think this is the sign where the problem comes from.

Any assistance in solving the situation is appreciated.

Attachments (2)

main.log (7.8 KB) - added by ksee.zelgadis@… 8 years ago.
main-2.log (209.6 KB) - added by ksee.zelgadis@… 8 years ago.
Full log file

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by ksee.zelgadis@…

Attachment: main.log added

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to lockhart@…
Port: openjade added

In the future, please fill in the Port field and Cc the port maintainers (port info --maintainers openjade).

This is not a clean build log. clean the port and try again. Then attach the new main.log file.

Changed 8 years ago by ksee.zelgadis@…

Attachment: main-2.log added

Full log file

comment:2 Changed 8 years ago by ksee.zelgadis@…

I have tried to build with the symlink pointing to "/tmp/skl/SynfigStudio" (instead of "/tmp/skl/SynfigStudio.app") and everything compiled fine. So, the problem with the ".app" part of the path.

comment:3 Changed 7 years ago by mojca (Mojca Miklavec)

Owner: changed from lockhart@… to tlockhart1976@…
Version: 2.2.1

comment:4 Changed 7 years ago by ryandesign (Ryan Schmidt)

Having the MacPorts prefix (or part of it) be a symlink isn't a well-tested configuration and may still be buggy. One such bug was fixed in MacPorts 2.3.0, so please try again after updating to MacPorts 2.3.1. But avoid symlinks in your prefix if possible.

comment:5 Changed 7 years ago by seanfarley (Sean Farley)

Resolution: fixed
Status: newclosed

I fixed this in r122971.

comment:6 Changed 7 years ago by ksee.zelgadis@…

Hello! Confirming: I have tested with the clean installation of the latest MacPorts and everything works fine now. Thank you!

comment:7 in reply to:  5 ; Changed 7 years ago by adamb2903

Resolution: fixed
Status: closedreopened

Replying to sean@…:

I fixed this in r122971.

You might have fixed this before, but it is broken now. Te situation was so bad that I removed *all* of my ports to make sure no malicious config file was hiding anywhere, reinstalled and, you guessed it, it's still broken. Try again, please.

comment:8 in reply to:  7 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: adam.bartley@… added
Resolution: fixed
Status: reopenedclosed

Replying to adam.bartley@…:

Replying to sean@…:

I fixed this in r122971.

You might have fixed this before, but it is broken now. Te situation was so bad that I removed *all* of my ports to make sure no malicious config file was hiding anywhere, reinstalled and, you guessed it, it's still broken. Try again, please.

The specific problem in this ticket was fixed in r122971, so let's keep it closed. The problem you're experiencing is different. See #44480.

comment:9 Changed 7 years ago by ksee.zelgadis@…

Looks like the problem is really back now, please see bugreport #46132.

comment:10 Changed 4 years ago by dholl (D. Holl)

#46058 explains how the fix in r122971 was reverted.

I started working on a fix in #46132 (which is similar to r122971 but sticks with sed instead of perl) which I'm testing right now.

While I'm waiting for my test to finish, I stumbled upon this ticket (#42434), and I got curious about what happened to r122971 from years ago.

comment:11 Changed 4 years ago by dholl (D. Holl)

Cc: dholl added
Note: See TracTickets for help on using tickets.