Opened 6 years ago

Closed 6 years ago

#42583 closed update (fixed)

redis: update to the lates (2.8.6 ATM)

Reported by: xeron (Ivan Larionov) Owned by: brianjlandau@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: petrrr, asahiro.g@…, nerdling (Jeremy L)
Port: redis

Description

Please update redis server to the latest stable version.

Attachments (1)

redis_2.8.7.patch (2.5 KB) - added by xeron (Ivan Larionov) 6 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to brianjlandau@…
Version: 2.2.1

In the future, please Cc the port maintainers (port info --maintainers redis).

comment:2 Changed 6 years ago by xeron (Ivan Larionov)

Thank you, will do.

comment:3 Changed 6 years ago by petrrr

Cc: Peter.Danecek@… added

Cc Me!

comment:4 Changed 6 years ago by asahiro.g@…

Cc: asahiro.g@… added

Cc Me!

comment:5 Changed 6 years ago by xeron (Ivan Larionov)

I've attached a patch to update redis to the current stable version. Tested it on the local machine.

comment:6 Changed 6 years ago by xeron (Ivan Larionov)

Guys, I believe maintainer doesn't care about this port anymore. Could someone apply and commit this fix please?

comment:7 Changed 6 years ago by petrrr

I do not believe this already qualifies for a abandoned port. (See also http://guide.macports.org/#project.update-policies.abandonment). And it is not even a maintainer timeout if counted from when the patch was provided.

Consider also, the maintainer has probably no commit right (judging from the mail address), so he will not be able to commit himself anyway. The port is openmaintainer so you can try to ping the developer list to ask for a commit. Anyway, you can try to contact the maintainer directly to ask if he is still interested in it.

comment:8 Changed 6 years ago by xeron (Ivan Larionov)

A bug has not been acknowledged for more than three weeks after a ticket is filed.

comment:9 Changed 6 years ago by petrrr

Okay, so fill a ticket and take over maintainership!

comment:10 Changed 6 years ago by xeron (Ivan Larionov)

Oh missed something – actually it's not a bug. But I think we won't see maintainer here anyway.

comment:11 Changed 6 years ago by petrrr

Well, you actually maybe right that the port is abandoned, but you cannot judge from this ticket alone. You need to look at the history, and that is what the abandoned port process is for.

Changed 6 years ago by xeron (Ivan Larionov)

Attachment: redis_2.8.7.patch added

comment:12 Changed 6 years ago by xeron (Ivan Larionov)

I've updated patch a bit with livecheck for port.

comment:13 Changed 6 years ago by nerdling (Jeremy L)

Cc: snc@… added
Resolution: fixed
Status: newclosed

Patched in r117933.

Note: See TracTickets for help on using tickets.