Opened 7 years ago

Closed 7 years ago

#42738 closed defect (duplicate)

p5.16-libapreq2 fails to build

Reported by: murrayeisenberg@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: p5-libapreq2

Description (last modified by mf2k (Frank Schima))

End of log (full log attached):

:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-libapreq2/p5.16-libapreq2/work/libapreq2-2.13/glue'
:info:build cd perl; /opt/local/bin/perl5.16  Makefile.PL -apxs /opt/local/apache2/bin/apxs INSTALLDIRS=vendor CC=/usr/bin/clang LD=/usr/bin/clang
:info:build Can't locate ModPerl/MM.pm in @INC (@INC contains: /opt/local/lib/perl5/site_perl/5.16.1/darwin-thread-multi-2level /opt/local/lib/perl5/site_perl/5.16.1 /opt/local/lib/perl5/vendor_perl/5.16.1/darwin-thread-multi-2level /opt/local/lib/perl5/vendor_perl/5.16.1 /opt/local/lib/perl5/5.16.1/darwin-thread-multi-2level /opt/local/lib/perl5/5.16.1 /opt/local/lib/perl5/site_perl /opt/local/lib/perl5/vendor_perl .) at Makefile.PL line 2.
:info:build BEGIN failed--compilation aborted at Makefile.PL line 2.
:info:build make[1]: *** [perl/Makefile] Error 2
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-libapreq2/p5.16-libapreq2/work/libapreq2-2.13/glue'
:info:build make: *** [all-recursive] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-libapreq2/p5.16-libapreq2/work/libapreq2-2.13'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-libapreq2/p5.16-libapreq2/work/libapreq2-2.13" && /usr/bin/make -j8 -w all 
:info:build Exit code: 2
:error:build org.macports.build for port p5.16-libapreq2 returned: command execution failed
:debug:build Error code: CHILDSTATUS 26885 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for p5.16-libapreq2: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port p5.16-libapreq2 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-libapreq2/p5.16-libapreq2/main.log

Attachments (1)

main_log_p5.16-libapreq2_install_try.txt (81.2 KB) - added by murrayeisenberg@… 7 years ago.
main.log for attempt to install p5.15-libapreq2

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by murrayeisenberg@…

main.log for attempt to install p5.15-libapreq2

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: build fails removed
Port: p5-libapreq2 added; p5.16-libapreq2 removed

In the future, please use WikiFormatting.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #42582.

Note: See TracTickets for help on using tickets.