Opened 7 years ago

Closed 7 years ago

#42795 closed defect (worksforme)

aquaterm @1.1.1 build fails due to sandbox violations in tracemode

Reported by: cooljeanius (Eric Gallager) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: g5pw (Aljaž Srebrnič), mojca (Mojca Miklavec)
Port: aquaterm

Description

Specifically:

--->  Building aquaterm
DEBUG: euid/egid changed to: 0/0
DEBUG: chowned /tmp/macports to macports
DEBUG: euid/egid changed to: 502/501
DEBUG: Tracemode will respect recursively collected port dependencies: 
DEBUG: Executing org.macports.build (aquaterm)
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm" && /usr/bin/xcodebuild  -target "AquaTerm" -configuration Default build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.6 ARCHS="x86_64 i386" SDKROOT="" GCC_VERSION=4.2 LOCAL_APPS_DIR=/Applications/MacPorts LOCAL_FRAMEWORKS_DIR=/opt/local/Library/Frameworks'
mkdir: /var: Permission denied
Failed to create'/var/folders/qF/qF8QQTpQEd46C36JGCgxkk+++TM/-Tmp-/xcrun_db'
Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm" && /usr/bin/xcodebuild  -target "AquaTerm" -configuration Default build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.6 ARCHS="x86_64 i386" SDKROOT="" GCC_VERSION=4.2 LOCAL_APPS_DIR=/Applications/MacPorts LOCAL_FRAMEWORKS_DIR=/opt/local/Library/Frameworks
Exit code: 1
Warning: An activity was attempted outside sandbox: /var
Warning: An activity was attempted outside sandbox: /var/folders/qF/qF8QQTpQEd46C36JGCgxkk+++TM/-Tmp-
Warning: An activity was attempted outside sandbox: /var/folders/qF/qF8QQTpQEd46C36JGCgxkk+++TM/-Tmp-/xcrun_db
Error: org.macports.build for port aquaterm returned: command execution failed

Will check whether it succeeds when I turn off tracemode after I attach my logfile...

Attachments (1)

main.log (18.6 KB) - added by cooljeanius (Eric Gallager) 7 years ago.
main.log for aquaterm failing in tracemode

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by cooljeanius (Eric Gallager)

Attachment: main.log added

main.log for aquaterm failing in tracemode

comment:1 Changed 7 years ago by cooljeanius (Eric Gallager)

Will check whether it succeeds when I turn off tracemode after I attach my logfile...

OK, checked, and yup, turning off tracemode was all that it took for it to succeed... Maybe this is an issue with tracemode itself? If that is the case, then I probably should have cc-ed cal, considering that he has been the main person working on tracemode...

comment:2 Changed 7 years ago by g5pw (Aljaž Srebrnič)

Interesting. I wonder if this is somehow connected with #42428? Is tracemode already released?

comment:3 Changed 7 years ago by neverpanic (Clemens Lang)

/var/folders and /private/var/folders are in the whitelist of trace mode. /var however, is not. This wouldn't be a problem if the build didn't try to mkdir(/var) – and it actually shouldn't be a problem when calling mkdir(2) for a directory that already exists (even though it's a symlink in this case).

comment:4 Changed 7 years ago by neverpanic (Clemens Lang)

I also cannot reproduce the problem. Aquaterm builds just fine in tracemode for me.

To answer whether tracemode is released yet: It has always been, but the version that's in the current latest release has serious bugs that make its results erratic at best.

comment:5 Changed 7 years ago by g5pw (Aljaž Srebrnič)

Resolution: worksforme
Status: newclosed

It looks like we hit a bug in base, then.

Note: See TracTickets for help on using tickets.