Opened 7 years ago

Closed 6 years ago

#42806 closed defect (duplicate)

rsync: failed to connect to rsync.macports.org: Connection refused (61)

Reported by: thibaud4988@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.2.1
Keywords: Cc:
Port:

Description (last modified by ryandesign (Ryan Schmidt))

how can I fix it? i am on MAc OS 10.9.2 i am using littlesnitch but i open the port 873 with the protocol 6

port -v selfupdate
--->  Updating MacPorts base sources using rsync
rsync: failed to connect to rsync.macports.org: Connection refused (61)
rsync error: error in socket IO (code 10) at /SourceCache/rsync/rsync-42/rsync/clientserver.c(105) [receiver=2.6.9]
Command failed: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/release/tarballs/base.tar /opt/local/var/macports/sources/rsync.macports.org/release/tarballs
Exit code: 10
Error: Error synchronizing MacPorts sources: command execution failed
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: /opt/local/bin/port: port selfupdate failed: Error synchronizing MacPorts sources: command execution failed
MacBook-Pro-de-Thibaud:~ thibaud$ port -d selfupdate
DEBUG: MacPorts sources location: /opt/local/var/macports/sources/rsync.macports.org/release/tarballs
--->  Updating MacPorts base sources using rsync
rsync: failed to connect to rsync.macports.org: Connection refused (61)
rsync error: error in socket IO (code 10) at /SourceCache/rsync/rsync-42/rsync/clientserver.c(105) [receiver=2.6.9]
Command failed: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/release/tarballs/base.tar /opt/local/var/macports/sources/rsync.macports.org/release/tarballs
Exit code: 10
DEBUG: Error synchronizing MacPorts sources: command execution failed
    while executing
"macports::selfupdate [array get global_options] base_updated"
Error: Error synchronizing MacPorts sources: command execution failed
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: /opt/local/bin/port: port selfupdate failed: Error synchronizing MacPorts sources: command execution failed

Change History (4)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: CcMe! removed
Component: portsbase
Description: modified (diff)
Type: updatedefect

Has it ever worked for you?

Does it work if you disable Little Snitch entirely?

comment:2 in reply to:  1 ; Changed 7 years ago by thibaud4988@…

Replying to ryandesign@…:

Has it ever worked for you?

no it never worked.

Does it work if you disable Little Snitch entirely?

I have tried it didn't worked.

I have maybe an idea. I am actually on a public wifi. it could come from that.

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 in reply to:  2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Replying to thibaud4988@…:

I have maybe an idea. I am actually on a public wifi. it could come from that.

Yes, it could. MacPorts uses the rsync protocol for selfupdate, which uses port 873. Some extremely restrictive networks might whitelist specific ports, like 80 for web traffic and 443 for secure web traffic, and block all others. If this is the case on the network you're using, talk to your network administrator about whitelisting port 873 as well.

comment:4 Changed 6 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

Duplicate of #43409.

Note: See TracTickets for help on using tickets.