Opened 7 years ago

Closed 7 years ago

#42827 closed defect (duplicate)

boost does not work after Xcode 5.1 update

Reported by: sandym (Sandy Martel) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: boost

Description (last modified by ryandesign (Ryan Schmidt))

using or trying to install from source results in compile errors:

/opt/local/include/boost/atomic/detail/gcc-atomic.hpp:961:64: error: no matching constructor for initialization of 'storage_type' (aka 'boost::atomics::detail::storage128_type')
    explicit base_atomic(value_type const& v) BOOST_NOEXCEPT : v_(0)

Change History (3)

comment:1 Changed 7 years ago by sandym (Sandy Martel)

duplicate of #42282

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: boost removed

comment:3 Changed 7 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

Yes this is a duplicate and it works now.

Note: See TracTickets for help on using tickets.