Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#42918 closed defect (duplicate)

py3?-matplotlib: variant +gtk3 broken, build fails

Reported by: petrrr Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: py-matplotlib

Description

I just realized that the +gtk3 is broken for Python 3.

  • I tested for Python 3.2, 3.3 and 3.4.
  • For Python 2.7 it builds correctly.
  • For Python 3.4 there are still missing some py34 sub-ports for specific variants including this one. Will be reported in a separate ticket;

I provide main.log files for the py32 and py33 build.

Attachments (2)

py32-matplotlib+gtk3.main.log (90.1 KB) - added by petrrr 6 years ago.
py33-matplotlib+gtk3.main.log (90.1 KB) - added by petrrr 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by petrrr

Changed 6 years ago by petrrr

comment:1 Changed 6 years ago by petrrr

Note that the missing dependency issue is documented in ticket #42920.

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: sean@… removed
Owner: changed from macports-tickets@… to sean@…

comment:3 Changed 6 years ago by petrrr

Now that the dependencies are available, I tested with python 3.4 and can confirm that I run into the same problem as documented here. I could provide the main.log for the py34 build as well, if this should be useful anyhow.

comment:4 Changed 6 years ago by petrrr

Has duplicate #43091! This seems to be due to a not specified dependency, which was in place on my system when I was testing for Python 2.7. The cited ticket provides a patch!

comment:5 Changed 6 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

Let's close this one and keep the one with the patch open.

comment:6 Changed 6 years ago by petrrr

Resonable!

Note: See TracTickets for help on using tickets.