Opened 7 years ago

Closed 7 years ago

#42936 closed defect (fixed)

php5-excel: error: redefinition of enumerator 'PICTURETYPE_PNG'

Reported by: erik@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: php5-excel

Description

Steps to reproduce:

sudo port selfupdate
sudo port install php5-excel

Expected result: php5-excel built, installed and activated

Actual result: Error: Processing of port php5-excel failed

Attachments (2)

main.log.zip (5.6 KB) - added by erik@… 7 years ago.
XCode502_main.log.zip (2.4 KB) - added by erik@… 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by erik@…

Attachment: main.log.zip added

comment:1 Changed 7 years ago by dbevans (David B. Evans)

Owner: changed from macports-tickets@… to ryandesign@…
Summary: Build fail on Mavericks 10.9.2php5-excel: build fails on Mavericks 10.9.2

Please CC maintainer when submitting tickets.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Status: newassigned
Summary: php5-excel: build fails on Mavericks 10.9.2php5-excel: error: redefinition of enumerator 'PICTURETYPE_PNG'

This must be a new problem with Xcode 5.1's version of clang; I currently have these ports installed (from November 19), but cannot rebuild them now.

comment:4 Changed 7 years ago by erik@…

Apparently same result on Mavericks 10.9.2 with Xcode 5.0.2 on another machine...

Changed 7 years ago by erik@…

Attachment: XCode502_main.log.zip added

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

Yes, I was mistaken with my initial assumption; the problem is an incompatibility with libxl 3.5.4.

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.