Opened 7 years ago

Closed 7 years ago

#42939 closed defect (duplicate)

Error: org.macports.destroot for port libgpod returned: error renaming

Reported by: mspivak@… Owned by: rmstonecipher@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: libgpod

Description (last modified by mf2k (Frank Schima))

Please explain in simple English how I can fix this problem. Thank you so much

Error: org.macports.destroot for port libgpod returned: error renaming "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libgpod/libgpod/work/destroot/opt/local/lib/python2.7": no such file or directory
Error: Failed to install libgpod
Please see the log file for port libgpod for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libgpod/libgpod/main.log
Error: The following dependencies were not installed: libgpod libkdcraw libraw libkexiv2 libkipi libksane sane-backends net-snmp liblqr marble gpsd libkdeedu opencv qt4-mac-sqlite3-plugin

Attachments (1)

main.log (178.9 KB) - added by mspivak@… 7 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to rmstonecipher@…
Port: libgpod added

Please attach the complete main.log after cleaning the port and, in the future, use WikiFormatting, fill in the Port field and Cc the port maintainers (port info --maintainers libgpod).

comment:2 in reply to:  1 Changed 7 years ago by mspivak@…

Replying to macsforever2000@…:

Please attach the complete main.log after cleaning the port and, in the future, use WikiFormatting, fill in the Port field and Cc the port maintainers (port info --maintainers libgpod).

I am so sorry but I don't understand the comment emailed to me. I just want to use digikam and when I run it I get the error above. I don't know what the main.log is or how to do too much except open a terminal and type in sudo port install digikam. Can you please explain. Thanks so much!!!!

comment:3 in reply to:  1 Changed 7 years ago by mspivak@…

Replying to macsforever2000@…:

Please attach the complete main.log after cleaning the port and, in the future, use WikiFormatting, fill in the Port field and Cc the port maintainers (port info --maintainers libgpod).

Can someone help? Thanks so much!

comment:4 Changed 7 years ago by neverpanic (Clemens Lang)

When a port fails to build it prints an error message that references a logfile we need to debug the problem. To ensure the logfile is useful to us, please run

sudo port clean libgpod

and re-try installing digikam. If it fails again attach the file given in the error output after Please see the log file for port xyz for details:.

Changed 7 years ago by mspivak@…

Attachment: main.log added

comment:5 in reply to:  4 ; Changed 7 years ago by mspivak@…

Replying to cal@…:

When a port fails to build it prints an error message that references a logfile we need to debug the problem. To ensure the logfile is useful to us, please run

sudo port clean libgpod

and re-try installing digikam. If it fails again attach the file given in the error output after Please see the log file for port xyz for details:.

It did not work. Thank you so much for your help! I attached the log file.

comment:6 in reply to:  5 Changed 7 years ago by mspivak@…

Replying to mspivak@…:

Replying to cal@…:

When a port fails to build it prints an error message that references a logfile we need to debug the problem. To ensure the logfile is useful to us, please run

sudo port clean libgpod

and re-try installing digikam. If it fails again attach the file given in the error output after Please see the log file for port xyz for details:.

It did not work. Thank you so much for your help! I attached the log file.

Thanks for your help! Does anyone have an idea on how I can get this fixed? I attached the log

comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #42874.

Note: See TracTickets for help on using tickets.