Opened 7 years ago

Closed 7 years ago

#42994 closed defect (fixed)

dbus: <dscl_cmd> DS Error: -14136 (eDSRecordNotFound)

Reported by: frozencemetery (Robbie Harwood) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cooljeanius (Eric Gallager)
Port: dbus

Description

robbie@osxserver:~$ port -d info dbus
DEBUG: Changing to port directory: /Volumes/ServerDrive/NetUsers/robbie/var/macports/sources/rsync.macports.org/release/tarballs/ports/devel/dbus
DEBUG: OS darwin/10.8.0 (Mac OS X 10.6) arch i386
DEBUG: Reading variant descriptions from /Volumes/ServerDrive/NetUsers/robbie/var/macports/sources/rsync.macports.org/release/tarballs/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Requested variant +gnutls is not provided by port dbus.
DEBUG: Requested variant +gcc48 is not provided by port dbus.
DEBUG: Requested variant +gpl3 is not provided by port dbus.
DEBUG: Requested variant +ssl is not provided by port dbus.
DEBUG: Requested variant +python27 is not provided by port dbus.
DEBUG: Requested variant +bash_completion is not provided by port dbus.
DEBUG: Executing variant startupitem provides startupitem
DEBUG: Executing variant no_root provides no_root
DEBUG: <dscl_cmd> DS Error: -14136 (eDSRecordNotFound)
    while executing
"exec /usr/bin/dscl . -read Users/${install.user} NFSHomeDirectory"
    (procedure "variant-no_root" line 15)
    invoked from within
"variant-no_root"
    invoked from within
"catch "variant-${name}" result"
Error: dbus: Error executing no_root: <dscl_cmd> DS Error: -14136 (eDSRecordNotFound)
DEBUG: Error evaluating variants
    while executing
"error "Error evaluating variants""
    (procedure "mportopen" line 56)
    invoked from within
"mportopen $porturl [array get options] [array get merged_variations]"
Error: Unable to open port: Error evaluating variants
robbie@osxserver:~$ 

System is 10.6.8, with a non-root macports installation. Please let me know if there is more information I can provide.

Attachments (1)

main.log (57.6 KB) - added by frozencemetery (Robbie Harwood) 7 years ago.
build failure main.log

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: mcalhoun@… removed
Owner: changed from macports-tickets@… to mcalhoun@…
Summary: dbus variant evaluation errordbus: <dscl_cmd> DS Error: -14136 (eDSRecordNotFound)

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

So I see you are using a non-root MacPorts installation and have selected the no_root variant, which runs the command

/usr/bin/dscl . -read Users/${install.user} NFSHomeDirectory

and this is failing, because this record does not exist. What is your MacPorts install user, according to macports.conf? Does that user in fact exist? What happens if you run the above command on the command line, substituting your install username for "${install.user}"?

comment:3 in reply to:  2 Changed 7 years ago by frozencemetery (Robbie Harwood)

Replying to ryandesign@…:

So I see you are using a non-root MacPorts installation and have selected the no_root variant, which runs the command

/usr/bin/dscl . -read Users/${install.user} NFSHomeDirectory

and this is failing, because this record does not exist. What is your MacPorts install user, according to macports.conf?

User is robbie.

Does that user in fact exist?

Yes, it's who I'm logged in as.

What happens if you run the above command on the command line, substituting your install username for "${install.user}"?

robbie@osxserver:~$ /usr/bin/dscl . -read Users/robbie NFSHomeDirectory
<dscl_cmd> DS Error: -14136 (eDSRecordNotFound)
robbie@osxserver:~$ 

comment:4 Changed 7 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Status: newassigned

This is probably a duplicate of #28121, but let's be sure.
dbus assumes that the user information is located on the local machine.
Are you logged in using Active Directory, Open Directory, etc.?
This command should give some insight:

$ /usr/bin/dscl
Entering interactive mode... (type "help" for commands)
 > ls
Local

Contact
Search
 >

comment:5 in reply to:  4 Changed 7 years ago by frozencemetery (Robbie Harwood)

Replying to mcalhoun@…:

This is probably a duplicate of #28121, but let's be sure.

Hmm, didn't think of that. Apologies in advance if that is the case.

dbus assumes that the user information is located on the local machine.
Are you logged in using Active Directory, Open Directory, etc.?

I believe so.

robbie@osxserver:~$ /usr/bin/dscl
Entering interactive mode... (type "help" for commands)
 > ls
BSD
LDAPv3
Local

Contact
Search
 > 

comment:6 Changed 7 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: assignedclosed

Hopefully, this is fixed in r118513.

I attempted to find the home directory using other means, but I do not think it will work for your situation (LDAPv3)
since it would require knowing the host name (see dscl manpage).
dbus should still install but issue a warning.

Please feel free to reopen if the problem still exists.

Changed 7 years ago by frozencemetery (Robbie Harwood)

Attachment: main.log added

build failure main.log

comment:7 in reply to:  6 ; Changed 7 years ago by frozencemetery (Robbie Harwood)

Resolution: fixed
Status: closedreopened

Replying to mcalhoun@…:

dbus should still install but issue a warning.

Warning yes, install no. It fails to build; main.log attached.

comment:8 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:9 Changed 7 years ago by neverpanic (Clemens Lang)

Maybe you should use dscacheutil -q user -a name ${install.user} instead? Or even simpler, [file normalize "~${install.user}"]?

comment:10 in reply to:  7 ; Changed 7 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Replying to rharwood@…:

Replying to mcalhoun@…:

dbus should still install but issue a warning.

Warning yes, install no. It fails to build; main.log attached.

I think that this might be a completely different issue.
The error seems to be

:info:build dir-watch-kqueue.c: In function ‘bus_set_watched_dirs’:
:info:build dir-watch-kqueue.c:262: error: ‘O_CLOEXEC’ undeclared (first use in this function)
:info:build dir-watch-kqueue.c:262: error: (Each undeclared identifier is reported only once
:info:build dir-watch-kqueue.c:262: error: for each function it appears in.)

I do not have any experience with O_CLOEXEC, but this link and this as well seem to indicate that 10.6 (which I see you are using) doesn't have O_CLOEXEC.
If this is in fact the problem, we should probably open another ticket for this particular problem.

comment:11 in reply to:  10 Changed 7 years ago by frozencemetery (Robbie Harwood)

Replying to mcalhoun@…:

I think that this might be a completely different issue.
The error seems to be

:info:build dir-watch-kqueue.c: In function ‘bus_set_watched_dirs’:
:info:build dir-watch-kqueue.c:262: error: ‘O_CLOEXEC’ undeclared (first use in this function)
:info:build dir-watch-kqueue.c:262: error: (Each undeclared identifier is reported only once
:info:build dir-watch-kqueue.c:262: error: for each function it appears in.)

I do not have any experience with O_CLOEXEC, but this link and this as well seem to indicate that 10.6 (which I see you are using) doesn't have O_CLOEXEC.
If this is in fact the problem, we should probably open another ticket for this particular problem.

As requested, I have opened #43370.

comment:12 Changed 7 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: reopenedclosed

Closing again since the new issue was unrelated and was fixed in #43370.

Note: See TracTickets for help on using tickets.