Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#43054 closed defect (duplicate)

py-graph-tool stuck at building stage

Reported by: absima@… Owned by: count0 (Tiago de Paula Peixoto)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: mamoll (Mark Moll)
Port: py-graph-tool

Description (last modified by ryandesign (Ryan Schmidt))

I have 2 upgraded macs (from lion to mnt lion + from leopard to lion). Last time I have graph-tool configuration issues on both of them as reported in Ticket #40072. Editing the Portfile then as suggested in r109300 solved the issue.

Recently, I have updated the port using sudo port -v selfupdate . Then as I upgrade outdated , the process got stuck for a couple of hours at

---> building py27-graph-tool

I then tried replacing the portfile by removing the following line, like the suggestion in r109300

PYTHON_LDFLAGS="-L${python.libdir}/.. -lpython${python.branch}"

so that it uses the following instead

PYTHON_EXTRA_LDFLAGS="-L${python.libdir}/.. -lpython${python.branch}"

This didn't solve the issue. Still stuck at building process.

I hope the issue might be known since these are the same laptops I reported about in the aforementioned ticket. Please, let me know if I could provide the log/main files like last time so that I could get it work again. Thanks

Attachments (4)

Screen Shot 2014-03-26 at 12.14.49 AM.png (128.1 KB) - added by absima@… 6 years ago.
main_from_Lion.log (84.9 KB) - added by absima@… 6 years ago.
main_from_mtLion.log (79.1 KB) - added by absima@… 6 years ago.
ImportError.pdf (26.1 KB) - added by absima@… 6 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by absima@…

Sorry, the heading should have looked like:

==The new portfile for py-graph-tool stuck at building stage==

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: mmoll@… added
Description: modified (diff)
Keywords: py-graph-tool removed
Owner: changed from macports-tickets@… to tiago@…
Port: py-graph-tool added

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Summary: The new portfile for pt-graph-tool stuck at building stagepy-graph-tool stuck at building stage

comment:4 Changed 6 years ago by mamoll (Mark Moll)

When you say that the process got stuck, what does that mean? Py-graph-tool takes hours to compile, even on very fast machines. The build process also uses large amount of memory. If you have 4GB of memory or less, the build will at some points probably start swapping to disk which will slow things down even more. Can you try to install using an unmodified Portfile like so:

sudo port -dv install py27-graph-tool

and type "top" in a terminal window when you think the build is stuck? If you see that "clang" or "kernel_task" is using lots of CPU, that means it is still compiling or swapping, respectively. If you still think there is a problem, please attach the log file.

Changed 6 years ago by absima@…

Changed 6 years ago by absima@…

Attachment: main_from_Lion.log added

Changed 6 years ago by absima@…

Attachment: main_from_mtLion.log added

comment:5 Changed 6 years ago by absima@…

yes, it took long when I installed previously. But, this time, it was strangely long. I left one of them running overnight; but it was still there.

About 3 hours ago, I did as you told me to. I see a series of warnings. I attached the screenshot from one of the Mac's. I also have attached the main.log files below. Please take a look at it and let me know if there's a fix. Thanks a lot.

comment:6 Changed 6 years ago by mamoll (Mark Moll)

The log files don't contain any information about the py27-graph-tool build. I still don't know if there is a build error or if the compilation is just very slow. Can you check "top" as I suggested above?

Changed 6 years ago by absima@…

Attachment: ImportError.pdf added

comment:7 Changed 6 years ago by absima@…

Yes, I have done your suggestions. After a really long time (4GB RAM Lion) compared to the previous installation duration it needed before, it seems that it's installed. However, it's still impossible to import it from python. It automatically triggers python to exit and shows me some path issue, I think. Or may be different. I have attached the error displayed on the terminal.

Besides, I could not find the log file by search as well as the from the specific place I would expect it to be

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-graph-tool/py27-graph-tool/main.log

comment:8 Changed 6 years ago by mamoll (Mark Moll)

Resolution: duplicate
Status: newclosed

Duplicate of #43086.

comment:9 Changed 4 years ago by elebv2005@…

I have a very similar problem. It is now 1hr 25 mins since the installation began. Current status looks like: ---> Cleaning sparsehash ---> Fetching archive for py27-graph-tool ---> Attempting to fetch py27-graph-tool-2.16_0+clang38+openmp.darwin_14.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/py27-graph-tool ---> Attempting to fetch py27-graph-tool-2.16_0+clang38+openmp.darwin_14.x86_64.tbz2 from https://packages.macports.org/py27-graph-tool ---> Attempting to fetch py27-graph-tool-2.16_0+clang38+openmp.darwin_14.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/py27-graph-tool ---> Fetching distfiles for py27-graph-tool ---> Attempting to fetch graph-tool-2.16.tar.bz2 from http://jog.id.distfiles.macports.org/macports/distfiles/py-graph-tool ---> Verifying checksums for py27-graph-tool ---> Extracting py27-graph-tool ---> Configuring py27-graph-tool ---> Building py27-graph-tool

after doing several other stuff above. Should I break and come out? What is the graceful way to roll back with no damage? Thanks.

comment:10 Changed 4 years ago by elebv2005@…

After I posted this it got out!! :) Thanks.

Note: See TracTickets for help on using tickets.