Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#43072 closed update (fixed)

portfile update of seqan

Reported by: tre@… Owned by: david.weese@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc: knut.reinert@…
Port: seqan

Description

Hi,

I made the following changes to the port seqan @1.3.1:

  • update to SeqAn version 1.4.1 (current stable release)
  • divided the former one port into two ports:
    • seqan now contains the header-only library
    • seqan-apps contains all SeqAn applications that we distribute (this port will be another ticket)
  • the include files of seqan are now simply downloaded and extracted into destroot
  • seqan-apps are now pre-built on our servers for i686 and x86_64 platforms which saves build time (took >30min and >4GB RAM)

You'll find the seqan portfile patch in the attachment and I'll add link to the new seqan-apps portfile ticket.

Attachments (1)

Portfile.seqan.patch (2.2 KB) - added by tre@… 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: knut.reinert@… added
Keywords: haspatch added
Owner: changed from macports-tickets@… to david.weese@…

Thanks. Some observations:

  • Since this port no longer installs binaries, it needs to so indicate by adding the line "supported_archs noarch".
  • Instead of "configure {}", write "use_configure no".

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Oh, and: please indent at multiples of 4 spaces, per our standard style.

Changed 6 years ago by tre@…

Attachment: Portfile.seqan.patch added

comment:3 Changed 6 years ago by tre@…

Thanks, I just updated the patch accordingly. Hope its fine now. As promised, here is the link to the 2nd portfile that now contains the SeqAn apps: #43080

Regards, David

Last edited 6 years ago by tre@… (previous) (diff)

comment:4 Changed 6 years ago by tre@…

ping

comment:5 in reply to:  4 Changed 6 years ago by tre@…

ping

comment:6 Changed 6 years ago by mf2k (Frank Schima)

Commenting with "ping" does not accomplish anything. The problem is that the maintainers are not responding to tickets, see #43649. You should send a message to Macports-dev mailing list if you want action on this.

comment:7 Changed 6 years ago by mf2k (Frank Schima)

Keywords: maintainer added
Resolution: fixed
Status: newclosed
Version: 2.2.1

Thanks. r119902. I also :

  • Removed the text about the license in long_description since that is what the license field is for.
  • Removed the knut.reinert maintainer email address.

comment:8 Changed 6 years ago by david.weese@…

Hi,

as described in #43649 I am the maintainer of this port and have two MacPort accounts david.weese@… and tre@… (my old one). I'm not sure what you mean with the maintainers are not responding to tickets. I didn't receive any mails I could respond to to none of the two addresses. Please add knut.reinert@… again as a maintainer (he is a full professor at the FU Berlin an director of the project).

We recently published the minor release 1.4.2 of SeqAn so I will send an update of the Portfile patch if that is ok.

Cheers, David

Note: See TracTickets for help on using tickets.